HA 2023-12.4 Bluetooth hci0/RuuviTag disconnects/reload

I’ve installed HomeAssistant “core-2023.12.4” on an Intel NUC NUC6I3SYK, native Ubuntu 22.04. I’m finding that HA recognizes the NUC/Intel Bluetooth device (hci0) and my RuuviTag. However, after about 30 minutes, the RuuviTag becomes disconnected and shows “Unavailable” in my dashboard/card. If I reload the Bluetooth integration, the RuuviTag values are properly displayed. This might be a refresh interval issue?

Two questions: (1) is there a refresh setting in the code that can refresh the Bluetooth connection or (2) is there an easy automation or script that can trigger the refresh?

Thank you

They recommend if possible, to use an ESP Bluetooth Proxy for more reliable (and faster) Bluetooth.

I believe this is a driver issue, happens to me on 4 NUCs. I wish I saved my logs this morning to show you, because this just happened to me on 2 of the NUCs, it happens frequently.

HA watchdog does try to restart Bluetooth, per the logs, but the only solution is a reboot.

I know HA doesn’t like the NUC Bluetooth device because on one of the NUC, I replaced it with a USB Bluetooth adapter and it works fine. While the other NUCs experience Bluetooth failures at roughly the same time and frequency, the 1 with the separate adapter functions well without issues.

Thank you – I will look into the ESP Bluetooth Proxy.

I found that I can recycle the bluetooth connection with ‘sudo rfkill block bluetooth’ followed by ‘sudo rfkill unblock bluetooth’. Takes a couple of minutes for HA to refresh the Ruuvitag.

1 Like

You should be aware though that the main reason they suggest the ESP Bluetooth Proxy (an m5 atom does the job fine by the way) - is because they say there are too many layers for bluetooth to be passed through on Linux, which causes a lot of the unreliability as well latency. The ESP Bluetooth Proxy is passing raw bluetooth data directly to Home Assistant over the network bypassing all the Linux bluetooth subsystem, and is thus much much faster.

Understood. I don’t want to add an ESP BT proxy for one sensor… My NUC server is mostly idle (file server).

The odd thing is I tried an old IOGear BT USB dongle with the proper drivers, and disabled the internal NUC BT adapter (BIOS), the connected Ruuvitag behaved the same. However, in restoring the original configuration, the RuuviTag devices are now working! I have no idea what changed. I’ll watch this for a while.

Thank you,

1 Like