HA and InfluxDB/Grafana


#1

Hi,

I’ve installed HA and my sensors and configured influxdb like this:
influxdb:
host: 127.0.0.1

It is working BUT sometimes I have gaps in my grafana graph. (i use the tado° skill for temperature)
Is there a settings to say HA how often it should send it’s values to influxdb?

at the moment i have to set the graph’S time interval to 20m+ … 5m+ would be great.

cheers j


#2

By default, HA doesn’t send data unless the value has changed, which results in gaps in the graph. Some sensors, like mqtt, have a force update parameter that sends a data point on a state update even if the value hasn’t changed.

There was a thread a month or so ago where someone was trying to resend all data periodically, but I don’t remember if they succeeded.


#3

You can configure Grafana to fill gaps, e.g. “Fill (previous)”. This will close the gaps in the graph.