HA Assist & USB Microphone

Just plugged in a USB Microphone, doesn’t seem to be ‘picked up’ by HA:

system | Hardware | All Hardware | event 3

from CLI:

ha audio info
  input: []

Select ‘Assist’ from the main screen, then the microphone icon - immediately get the message
<Home Assistant did not hear anything>

I don’t think you can do it that way; I think you’ll need to try doing it with a microphone on the PC you access the HA server from, just like how it works in the mobile apps.

Already tried that
Select ‘Assist’ from the main screen, then the microphone icon - immediately get the message
<Home Assistant did not hear anything>

It may not be set up to do that yet, then. I also can’t do it from Firefox at all, but the microphone icon does show up in Vivaldi, Chrome, and Microsoft Edge.

I believe that there needs to be a cookie to turn on the microphone as my browser Edge reports this

If I change the option to ask it does not take.
I am running Home Assistant Operating system 9.0 and Home assistant Core 2023.2.3

1 Like

I also don’t have a microphone icon in Firefox (despite opening every permission I can find), but I do see one in Brave (though clicking it in Brave instantly returns <Home Assistant did not hear anything>.

If someone knows how to allow the HA web interface access to the microphone in Firefox I’d appreciate some help.

it’s know since long, but stil no solution for this, for what i know

Still works fine in EDGE thou

Home Assistant 2023.3.6 
Supervisor 2023.03.3 
Operating System 10.0.rc1 
Frontend 20230309.1 - latest

Ha in VMWare on Laptop

EDGE (even) on another Windows laptop, works with builtin microphone, as well as 1 usb head-set and 2 other “very old” usb microphones … plugg and play … all works just fine

However …

Please don’t forget that Browsers are just another peace of software, not particular “intelligent”
So don’t expect it should/would i.e change from built-in to plugg-in during a “session” , i think most requires that you close the browser and open again

Thou my logitec headset set , i can plug-in, plug-out, builtin takes over, plug-in again working as soon as windows registered the headset again

With 2023.5.1 I still get this from Edge or Chrome on my laptop.
However I can use it on my Samsung Table and Phone using the HA Companion app?

Yes, I don’t have https implemented on HA Core running on a NUC-i3
but I thought that was unnecessary with Nabu Casa?

Assist is interesting but implementation needs explaining a bit more to us low level people.

1 Like

@oldfart101 If you are using it from a URL besides https://, file:///, or localhost, then in all Chrome based browsers mic access cannot be granted. In Firefox, you can manually enable it by pressing CTRL+I to see permissions and turning microphone on.

In EDGE You can add this to the “about:config” page

that would be without the "command-line flag, and last “. NOTE” :wink:

1 Like

Edge has no about:config page, it does have edge://settings, but not that option.

Sorry , i forgot :slight_smile: (hardly ever use EDGE ! )… but i found it for you :wink: … as the 1st pic is take from my browser, and it works

1 Like

Ah, flags. :slight_smile: I use them quite often. Also, available in Chrome and Opera at chrome://flags. I don’t know if Opera has that one, but thanks for mentioning. :+1:

1 Like