HA backup and restore

I am trying to restore a backup of HA onto a different Raspberry Pi B. Both the old and new have USB external drives for storage.
I boot up the new PI and chose restore from backup - full backup but it fails and has done at least 5 times and I have no idea why.
The reason I am trying to do this is a cold standby if the running PI fails.
Any suggestions on why this keeps failing or other options?

If the backup is to big, it can fail. Go through onboarding, upload your backup, and restore from there

It’s about 800MB. Tried that method too and it fails still.

Anything in the logs?

Nothing in the logs. Tried to do the restore after onboarding got this error…
‘BackupManager.do_restore_full’ blocked from execution, no host internet connection

That makes no sense as the R PI does have an internet connection.

Hi, is the first RPi still running and maybe with the same IP address?

No the old PI is switched off. I finally got it working.
I after onboarding I changed the hostname of the homeassistant to homeassistantnew, chnaged the DNS from (local router) to then rebooted my router then did the restore and it worked. I think there was a DNS problem and the two hostname orignally being the same.

Anyway its working now.

1 Like

Good you got it solved!

It often is…

Now, before you go… please take the time to mark the solution as the answer, you do that by selecting the three dots under the post:


Then select the check box:

By doing so this can be useful to other users as well and prevents that someone else steps in and still tries to help you.