HA brings Raspberry Pi to near halt after installation

Dear Community,
I seem to have a rather wheired issue with homeassistant, and it’s installation.
For context:
I am using a Raspberry Pi 3B
I have installed raspbian desktop without recommendet Software on my pi a couple of days ago, because I need a UI in order to launch several applications at the same thime and look at their windows.
I have the Mosquitto MQTT server installed already,
and zigbee2mqtt is running with a cc2531 zigbee adapter.
To get Python 3.8 running on the Pi, i compiled it myself with the following instructions:
I don’t know if that matters but i compiled Python on all 4 cores (as stated in the instructions) and the pi got to over 82°C before I realizid it was getting hot, then i used a fan to cool it down to around 40°C (I do have a heatsink on my Pi). Then i went to install HA Core with the instructions on the HA website:
When i was as far as installing HA using pip, it already took painfully long, and it is definitely not my Internet connection that is causing troubel here. Anyway, once it finally finished and I started it using the hass command, it really went of. Now not really much was happening anymore. The Pi became really inresponsive, it did react to some things, but the kernel was almost frozen, the desktop didn’t really do anything, and the charts in the top right hand corner of the pi showing temerature and CPU load where frozen at some point. After some time Home Assistant did give the following Error messages (I only have a foto of the screen, because i couldn’t copy the text anymore as it was frozen):

(In the image you can see i am not using the newest version of pip, because even if I install it using the provided command, it still doesn’t use the newest version)

At that point I restarted the Pi using the reset jumper. I rebooted it a few times properly afterwards and tried again, only to see that HA was doing even less than before. It eighter put out nothing on the command prompt, or warned about an unfinished session but no more.

I may note that i have also tried installing using venv before with the same result and the same slow installation.

Thats where I am now. I don’t know what i did wrong, I even thought about a CPU Core beeing damaged by overheating, though that seems quit unrealistic.

I hope someone can help me

Hello… Your installation steps and procedures seem correct to me (I migrated my environment to python 3.8 and used the same installation procedure except that my HA environment was already configured)… Can you share the content of home-assistant.log ? One thing that you can do is to use: “hass --script check_config” instead of just “hass”…

I would have wanted to look into the home assistant log file, but it isn’t in the homeassistant folder, also HA didn’t create a subfolder .homeassistant. It pretty much got stuck on “No Configuration found, Creating a new one” but it didn’t. Then it started to through errors of stuff taking to long and at that point the system was pretty much frozen. In case the log file is not located in this directory, where is it?

I have used the check config command, and it sayd it wanted to install colorlog. Then it said:
Testing configuration at /home/homeassistant/.homeassistant
and then the command endet.
I didn’t know the config was in that directory. I have had an older version of HA installed previously but it was all different back then. So now i knew the directory, i checked the log file. It said the same thing it said on the foto of the terminal window.

Did you try to connect on your system using http://ip_address:8123 ?

That’s a good point, and i think i found my problem. Now I still don’t know how the system could feez, but I have now updated pip using
$ /srv/homeassistant/bin/python3.8 -m pip install --upgrade pip
while in the context of the venv, and it seems to work now. when i start hass again, it does not produce any output, before i updated it sayd something like it coudn’t install colorlog. But now it works, doesn’t produce any output and it appears in the webbrowser. So I guess I was just thinking it should give outputs, because it did with older versions. Anyway it seems to work now, thank you very much for the quick reply

1 Like

I think pip changed the way it works recently… So upgrade to the latest version is generally a good move… Happy that your system is up and running !