HA causing high latency / lagg to tasmota-sonoff devices

Tags: #<Tag:0x00007f739b0ab8b8> #<Tag:0x00007f739b0ab610>

Hello,

So long story short: I’ve multiple RPIs around the house controlling different areas. All of them running node-red only. Most of my automation written only in node-red. Tried to switch one with hassio. Overall worked quite well, but suddenly it was terribly laggy. Basically not only hassio controlled relays were reacting slow, but my sonoff-tasmota devices as well.

Tried to install 3rd party mqtt for the hassio. Separated the mqtt massages so i had two broker with no sonoff devices. But the sonoff devices were still bad beheaving.

Tried to turn off the hassio installed rpi and everyting was working normal again.

Does anyone seen some similar issue? What can cuse the sonoff lagg even with separated broker on it? Tried to sniff all mqtt messages for both broker but message sequnace were fine, but the device itself had some lagg still to turn on or off the relay.

Thanks for any tip in advance.

At what point did the setup stop working? What was changed? You can check the logs as well for any error messages.

Can you access sonoffs via the web UI? Try toggling them there. The fact all are affected means the problem is probably within HA or MQTT server.

Send a test MQTT message and observe how quickly it switches your sonoffs. Do this from HA and from a MQTT tool such as MQTT.fx. report your findings.

I’m thinking I am experiencing similar/same issues. Just loaded up HA on a Pi and now my Tasmota-ized Sonoff Basics are TERRIBLY slow. It was working just fine before. I am going to shut off my HA for a bit and see what happens…