HA companion app crashes after update

HA companion app is crashing on startup on MacOS. How to go back to previous version?

Termination Reason: Namespace DYLD, Code 1 Library missing
Library not loaded: ‘/System/Library/Frameworks/ThreadNetwork.framework/Versions/A/ThreadNetwork’
Referenced from: ‘/Applications/Home Assistant.app/Contents/MacOS/Home Assistant’
Reason: tried: ‘’ (no such file), ‘/System/Library/Frameworks/ThreadNetwork.framework/Versions/A/ThreadNetwork’ (no such file)
(terminated at launch; ignore backtrace)

I think the Supervisor is crashing and that may be brining the companion app down.

It is critical that I find a way to get this running again. Any help would be most appreciated.

When Home Assistant OS starts I am getting:

Waiting for Supervisor to startup…
System Information
Error returned from Supervisor: System is not ready with state: setup

How to get back to a working state?

After considerable effort I was finally able to find the slug-id for what I believe is a partial backup of core_2024.1.6. However if I try to sue the HA CLI it gives an error and says this is a partial backup. I don’t have Ssh access. How do I restore the failing component?

I managed to get it working again with the ‘supervisor repair’ and the 'core update --version=Core_2024.1.6 commands. Still not sure what the problem was.