HA Compatible Energy Consumption Meter - Australia

+1 for IotaWatt. Its been rock solid since I put it in.

I also have solar, and annoying my solar service only measures generation, not anything about consumption, so the IotaWatt has been a life saver there!

As mentioned previously, you can integrate the direct stats into HA via REST, or run EmonCMS locally, and integrate both HA and IotaWatt into that.

I recently also integrated IotaWatt into PVoutput, and whilst yes its cloud, to get energy cosumption data, rather than just power, it makes life easy.


@jimpower did you end up creating you blog post/write up?

Can someone possibly post a list of all parts required for IoTaWatt and where you purchased them from?

Just buy the Aussie kit direct from iotawatt (with as many CT’s as you want to monitor circuits) then purchase the 9Vac power supply from your local Jaycar store. You can use any old 5Vdc power supply but iotawatt do list a odel from Jaycar as well.


I have a mid 70’s house in Perth with 3 phase power.

I want to monitor all circuits and I am looking to install solar in the future

What size CT’s do you think I need? Just get all large? Do you only need smaller for light circuits etc?

Also - how do you get power to the iotawat? did you get a powerpoint mounted inside your meter box?

Hoping for some steer from your experiences


Hi Phil, I’m Perth too!
I installed 50A CT’s on all circuits including the 3 phases of the supply. Depending on how heavy your power usage is you may need 100A CT’s on the supply phases but it’s unlikely.
I installed (since I’m an electrician myself) an outlet in the roof space above the switch board to plug in both the 9Vac and 5Vdc supplies. The iotawatt sits in the roof just above the board. My only concern is that the iotawatt might not like the heat up there in summer… something I will try to work around in the near future

1 Like

Thanks Dave!

I have 3 phase supply & a 3 Phase 15kW Fronius Inverter.

I was wondering how many CT’s I would need

3 x Incoming supply
3 x Solar Feed (or not needed as can use the Fronius HA monitoring?) I currently have it showing current power and daily today
1 x Oven
1 x Cooktop
1 x Aircon
1 x Hot water
4 x Power
2 x Lights

So 16 total or 13 if I don’t need any for the solar. I see the iotawatt is 14 max.

Alternatively, can I use 100A CT’s around all 3 cables for the the solar and main feeds?


Don’t worry about these, just get the data from the Fronius directly. I have the same solar inverter.

No, this will give you a reading of ZERO… without explaining how 3 phase power works, this is not it.

I max’ed out the 14 inputs on mine and had to group my 2 light circuits together, which is fine, but will only work for you if they are wired to the same phase.

I am thinking of building a monitor like this one https://www.rogerfrost.com/an-electricity-usage-monitor-with-home-assistant/

Has anyone done anything similar with an EDMi Atlas 2000-1010? The Powerpal ( https://reductionrevolution.com.au/products/smart-energy-monitor-app ) says it works with the Edmi Atlas Series so I am hopeful? On my meter I see a red LED flashing in PO3. See pic.

I have solar as well though so I can see that I will have trouble working out my exact consumption. This I expect will only tell me what I am importing… When I am importing and producing I can work it out but not when I am exporting…?


Depending on how much you want to spend and how handy you are - i would highly recommend the IOTAWatt with CT clamps.

I have purchased one recently - ended up costing about $300 AUD all up landed here with clamps for 10 channels - then purchased a reference power source from Jaycar.

Aboslutely brilliant how ti works and the info it produces - depending on if you are 3 phase or single and how many loads you want to monitor you can go upto 13 CT inputs.

It will output direct to inlfux, or EMONCMS and has rest apis to query it to populate into anything else you want


1 Like

Hi Phil:
May be you can consider about WEM3080T
it will pass the AU certification in 3 weeks and get the RCM certificate.
this is a hardware installation video, https://www.youtube.com/watch?v=xoj6jcxxA-E&feature=youtu.be
you do not need to prepare extra power socket for the energy meter.


Hi OzGaz,
I have a very similar setup. I have solar (and get the PV output from the inverter over wifi, thank goodness) but also get stuck with the grid consumption.

I used a pulse meter (like PowerPal) to read the red flashes that correspond to energy use. My model is the Atlas MK7c, picture attached.

I used this ESPHome cookbook entry as a guide (Non-Invasive Power Meter) I used a D1 mini and ran cable (cat5 cable repurposed to run the 5V, GND, data to the box. In the box, as you can see, is a light sensor stuck on top of the blinking red light. The blue tac is holding the sensor on + keeping light out. I only just got this up and running a few weeks ago so haven’t properly tidied it up. Some tips: when testing this, turn off your solar and run a high wattage appliance like the dishwasher, oven, air con as you need it to blink to actually work. Interestingly (i.e. frustratingly), the sensitiviy setting on the sensor (adjust with screwdriver) needed to be set for when the power meter lid was closed. Strangely, light was getting in somehow and messing with the readings.

I tried a few different ESPHome sensor settings, but this one worked for me (and probably works for your model given it’s the same brand):

#### ESP HOME config, not in home assistant
  # usage right now in kW
  - platform: pulse_counter
    pin: D4  # change your pin to whatever you're using
    unit_of_measurement: 'kW'
    name: 'Grid energy usage'
    id: power_meter
    internal_filter: 10us # Cookbook article says ESP7266 (i.e. D1 mini) can suffer too much noise and needs internal_filter, and count_mode set.
      rising_edge: DISABLE
      falling_edge: INCREMENT
      - multiply: 0.06 # (This number is calculated by dividing 60 with the imp/kWh of your power meter)
    update_interval: 30s
    accuracy_decimals: 1

Hopefully the above helps some poor bloke who is trying to figure this all out.

Thanks Tom. I made something similar to you but it seems my meter flashes for reasons other than reporting energy use. It was pretty much a constant pulse rate so ended up being no good.
Was a handy experiment though!

I agree very happy with Iotawatt except my switchboard is now full of CT’s :grinning:

Have you noticed any discrepancies with your iotawatt readings? I have a CT on each circuit plus the incoming supply and the sum of all outgoing circuits does not match the grid reading. I’ve been meaning to look into it for a while but haven’t had time. The values are way off. I’m on 3 phase power and initially thought I had a setting wrong (selecting the wrong phase for a circuit or two) but I double checked and they are all correct. Interested to know if you have checked outgoing circuits vs grid total

Hey Dave,

Nope i am not seeing any strangeness.

I have a 3 phase switchboard and have clamped the 3 inputs to that - so i get total house draw.

My 2nd IOTAWatt has just arrived as have the clamps so i will be clamping the solar inputs and the 3 phase from the grid so that i can get total consumption etc.

With my current setup i find that all 3 phases match up to each of the loads that i have instrumented - and more importantly with what i think i should be getting charged for

There is a bit of juggling of calculations as i am currently having to pull data from Iotawatt for consumption, Solar production from its app and then Grid draw from a hard wired meter


Hi Dave

Could PF have something to do with it?

No, this is purely a discrepancy between the total of outgoing circuits and what I’m reading from the grid (and it’s a huge difference sometimes). I think it must be a setting in the iotawatt somewhere.

EDIT: I just logged into the iotawatt and looked at the settings and outputs again… starting to think it is due to pf given that the overall grid pf is so low due to being a combination of my loads and the solar generation. I’ll do a comparison at night when there is no solar generation

1 Like

Are you on 3 phase ?

There was a good write up in Bobs blog on the IOTAWatt forum about making sure everything is setup correctly with the inputs.

I worked out when i deployed a Sonoff PowR2 that i was seeing some weird stuff in IOTAWATT - tracked it down to EBAY CT clamps that were not labelled correctly and needed to be reversed.

I thought for a while there i had the worlds most efficient Pool Pump


I’m on 3 phase, using the iotawatt supplied CT’s and the Jaycar VT. I’ve triple checked the CT’s but a forth time can’t hurt! I didn’t get around to checking night time values as I keep forgetting :man_facepalming:

Have a look in Bobs blog on the recent posts - he has a very good step by step on how to make sure you have phases identified correctly.