HA Core doesn't start after adding a custom component

I’m on 0.105.2 and my front end doesn’t load any more. I added a new custom component.

The thing is I had issues with this before this week but I thought they were related to the netatmo changes. So I had to restore from a backup. Everything was fine the last two days.

I also faced other issues with this component, which may be relatated.
The thing is this component is a fork of the ecovacs component and I tried to use both components (see in the link why). So both components made entries in the core.entity_registry file for both vaccuums and they had the same unique id (just want to add that in case that is import). Also tried to delete those entries in one of my last tries.

Today I added the deebot component again and it worked fine for some hours, but some hours later when I added a sensor and had to restart, ha core doesn’t start up any more.
I also tried rebooting hassio, also without luck.
I still have access via ssh and samba. So I delete all that was related to that component and tried restarting ha core. Without success:

hassio homeassistant restart
Processing... Done.

But I can’t see a related error in the logs. The only one I see are some like these:
but this seems to be only a cosmetic issue and was probably there before. However I also tried commenting out this component (which worked fine for months), but also no luck.
Hassio homeassistant check succeeded, so the config is fine.

Any ideas?

Edit: Will restore to a backup a few hours before adding the component. Still would be interesting why this happened two timed, because I would really like to use that component.

I am also having issues with all custom-components and had to remove all after upgrading to 105.2. I would really like to be able to run them again. If I try to add a custom-component, the configuration.yaml cannot pass the check.

I don’t think this is the same issue, because for me the configuration check passed. My instance works fine again after restoring and not installing the deebot component again. However I will soon retry deebot to make sure it wasn’t something else.