HA crashes every day after migrating to from SD to SSD

I migrated HA from my SD card to an SSD on my RPi4. Made a backup. Installed on SSD. Reconfigured RPi4 to boot from SSD. Booted into fresh installation. Restored from backup.
I lost a couple of Helper Variables and had to reinstall Tuya to get the devices talking again but beyond that all worked fine.

From that point on I have had HA crash every day. Connections to devices get lost and when I try to reboot, I get “missing configuration.yaml file”. I’m not familiar with the backend and have never used SSH before. I don’t even know if I have SSH set up properly. I’ve just been cycling the power since it refuses to reboot.

Any help would be greatly appreciated. I’m lost in the woods!


How are you powering the SSD? Using a powered hub seems to be highly recommended.

I’m using a 3A USB C power supply to the RPi4. The SSD and a zigbee dongle are plugged into two USB ports. I never thought about power supply issues. I wonder if using a 5A supply would give it what it needs or if I have to look at a powered hub. Thoughts?

Should probably try a powered hub; it’s not only an issue of the power supply to the Pi but it’s own limitations on how much power it can supply via USB.

Yup. Make sure its a USB2.0 though, not a USB 3.0 which will interfere with the Zigbee stick. Unfortunately they seem to be getting harder to find - on Amazon at least.

The Pi is hard limited to USB amperage at the plug. A larger amperage plug will only ensure it has max draw available. Unfortunately the Pi has a habit of drawing more than us can provide with an SSD and a full compliment of usb dongles. Providing power directly to the USB bus in the form of a powered hub can help.

You could also have new memory pressure but. You won’t know unless you’re watching the performance counters. I’d do power first and if that doesn’t do it start looking hard at memory utilization unless your SSD is over a year old (the look for disk issues)

Oh crap! I just ordered a USB 3 from Amazon! I can keep the zigbee stick on the RPi4 and maybe that will work.

No it is not recommended to plug the sticks directly into the Pi usb ports because USB3 bus interference is a thing.

Its the same reason the recommended a USB2 hub instead of 3.

Id order a USB2 hub and cancel the other order tbh

So I guess the only option is to find a powered USB 2 hub and plug both the zigbee and the SSD into that?

Kinda sucks that USB 3 presents problems for zigbee. Strange to me.


We make recommendations for valid reasons.

USB3 operates at just about 3ghz.

Zigbee and Bluetooth operate at 2.4ghz.

USB3 HDD/SSD signals play havoc with zigbee. Use the extension cord / USB hub. In your case you need power. Use the hub

Nuts! I see the point. I found a USB 2.0 4A powered hub and ordered it. Hopefully, my problems will be solved.

Thanks for all the help. I’ll know in a couple days if it works. If not, I’ll be asking again!

1 Like

Make sure all your coordinator sticks (ZWave / zigbee) are specified in thier relevant configuration areas by-id so when you move them to your hub HA will still find them

Added bonus you can just move the whole hub and all your sticks go with them. It was how I upgraded from Pi to NUC

1 Like

All works well again! Thanks for the help!