HA does not boot off new Flashed card

Using BalenaEtcher to install the Raspi3 version of HA as shown in the instructions:

After flashing the card, putting it in the Raspi3 for 1st time and turning on. No boot, No green light of activity, nuffin :frowning:
Continued this on several cards to try and get it to work, but no failed every time to even provide a glimmer of a green activity light on the old Pi.

Checked the Raspi, does it actually function, yes it does. Used a fresh install of Rasp-light, latest copy, and yes all bursts in to life. Even did this using the same cards as I had flashed the HA image on.

Also followed the instructions here (which I prefer to do):

So, installed Debian 10 (on one of the flash cards I had used in the above experiment) configured host name, forced the router to reserve its IP and updated. Added in docker CE, all working correctly, booting ok etc. made sure everything was updated.
went to install the HA bits etc. All seem to install in to Docker ok Tried to connect to 8123 as per expectation. Nope, no cookie for me :frowning:

Did a little digging on what was available:

  • ports 22 & 4357 were open
  • attached to 4357 via Chrome browser: Home Assistant observer, Supervisor Connected
  • Saw in Docker that 4357 was being repointed to port 80 (expected etc.)

Well, I’m not a Docker expert, but I’m assuming that there is meant to be some pointer to the HA landing page container? a redirect of port 8123 to the container’s port 80?

Any help guidance would be most appreciated, going out of my mind a bit here, well already a fruit cake!!
Cheers,
Garry

Hi,

I followed that exact guide with no issues so…

If I was you I would install Portainer which will let you see if the docker containers are running etc.

Mine looks like this but there is no port 8123 shown (maybe a redirect?) BUT my HASS has been working for 3 months like this, no issues.

Good Luck

Simon

Cool thanks for the pointer, but all seems to be identical:

I can see the Supervisor on port 4357, but nothing on 8123 and the app does not connect. Used nmap to show ports for which only 22 & 4357 were the only ones up.

Looks like you don’t have home assistant installed. Its a separate container from supervisior.

If you look at the 3rd line up in my pic, thats Home Assistant.

Maybe try the curl lines again?

sudo -i
curl -sL “https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh” | bash -s

Simon

Ha ha tried that again without success, so dug a bit deeper in to the Docker images that were available.

and behold, HA image was there, hiding!!
image
so, did a ‘docker run homeassistant/raspberrypi3-homeassistant’ to attempt to run it but it’s now doing another fetch:
Screenshot 2021-03-28 at 12.36.47

Lets see how that pans out. Not sure if I’m using the right commands, but hey learning though!!

Cheers,
Garry

Ok so I’ve done a completely new install and added Portainer ce to it too:

  • ha stayed up for about 20 minutes before collapsing.
    logs say:

2021-03-31T07:42:14.333928000Z [s6-init] making user provided files available at /var/run/s6/etc…exited 0.,
2021-03-31T07:42:15.001392000Z [s6-init] ensuring user provided files have correct perms…exited 0.,
2021-03-31T07:42:15.026262000Z [fix-attrs.d] applying ownership & permissions fixes…,
2021-03-31T07:42:15.064500000Z [fix-attrs.d] done.,
2021-03-31T07:42:15.083099000Z [cont-init.d] executing container initialization scripts…,
2021-03-31T07:42:15.110740000Z [cont-init.d] udev.sh: executing… ,
2021-03-31T07:42:15.215910000Z [cont-init.d] udev.sh: exited 267.,
2021-03-31T07:42:15.363721000Z [cont-finish.d] executing container finish scripts…,
2021-03-31T07:42:15.390205000Z [cont-finish.d] done.,
2021-03-31T07:42:15.407261000Z [s6-finish] waiting for services.,
2021-03-31T07:42:15.696369000Z [s6-finish] sending all processes the TERM signal.,
2021-03-31T07:42:18.748595000Z [s6-finish] sending all processes the KILL signal and exiting.,

So the exit with 267 would appear to point to an error in the script. Anyone have any suggestions?

Rest of the containers look fine: