HA does not work when on a different VLAN than SWAG reverse proxy

Hi All,

I’m trying to get localtuya to auto discover bulbs, but it isn’t working. HA and SWAG are currently on the same docker network. I’m using pfsense. The bulbs are on the IOT network. I have a firewall rule allowing the bulbs to talk to HA and SWAG. I get the 3 dots to configure the bulb, but no auto discover. I also have avahi running trying to broadcast packets to other subnets without luck.

So I tried to put HA on the IOT network. SWAG remains on the docker network. HA fails to start. I have rules for HA on IOT to communicate with needed IP’s on docker net. Does anyone know why HA won’t work on a separate VLAN from SWAG.

Do you have mcast enabled on all networks? Does the HA and SWAG have same IP address or different? Where pfsense?

Do you have a rule to Allow All and related on LAN IN in the pfsense? Should be at the very top

What firewall rules on the SWAG itself if any?

Avahi on pfsense is listening on all networks. Maybe avahi isn’t working so well.

With HA working, HA and SWAG have their own IP addresses in docker network Pfsense is on the LAN at Docker network can go anywhere just like the lan network. SWAG does not have any firewall rules other than port forwarding on the WAN interface to SWAG.

When I moved HA to IOT, it was in the space. I had a firewall rule for HA to talk to SWAG, MQTT, and Frigate. In the HA logs, there was red everywhere. I couldn’t connect to MQTT, Frigate, and regular web addresses like api.github.com. Having HA and SWAG on different networks killed HA even with rules allowing otherwise. I know the rules work on IOT because I have Jellyfin, which is on docker net, talking to my TV’s on IOT.