HA doesn't see my Aqara Hub M2

I have installed an Aqara Hub M2 and it’s well recognized in Apple’s homekit, can see it there under the bridge section, can also see the 2 door sensors which I added as well. Can also create an automation with the door sensors.
But in HA nothing shows up. Can’t see the bridge or the sensors. Tried to add integrations Xiaomi Gateway (Aqara) but it doesn’t work.
Any idea?

its solved, I deleted the Hub in Homekit and added it via HA’s HomeKit Controller

Hello, how did you connect to HA? The HomeKit Connector didn`t find my M2. I have deleted it in the Aqara App.

Sorry for some reason I didn’t see your message.
Not sure to understand, first you need to add the Aqara hub in Homekit, did you do this ?


How did you solve the issue of Aqara Hub M2 not showing in Home Assistant.
I have Apple’s Home app in I Phone and Aqara Hub M2 is showing up.
Can you help to solve the problem

After you have added the Aqara Hub into Apple’s Home app you need to delete there afterwards, Only then it shows up in Home Assistant

1 Like