HA + ESP32 + VBOX + ZYXEL don't work


I have been trying to get this combo working but it’s still not working. Now I think esphome has been installed to ESP32 succesfully but I can’t connect to it and it keeps staying offline in web-interface.

Picture as attached is the last error message which i got.

-VBox is running on ubuntu / laptop
-There is no internet connection on zyxel
-Laptop is connected to the zyxel by a cable
-Laptop has a wireless connection to internet
-VBox network is configured to use enp3s0 and is on bridged mode
-Zyxel is also configured to bridged mode



the device was already flashed, right?
OTA updates are only working if an older firmware was already flashed via ESPHomeFlasher, direct connected device or WebSerial.

If this was done already, it seems that mdns does fot work on your network.
Have you set a static IP for the device at your router?
If yes, you can set it at the wifi-settings at „use_address“. The OTA flashing process will use this IP than too to connect to it.

See documentation:

If this does not help, check if ESPHome and the device are connected to the same network or if VLANs are used the traffic is allowed between both VLANs.

Thank you for your help! I’m not sure about flashing. This is the screen which I get. I think flashing has been done correctly?

I’m bit confused because it doesn’t say clearly anything like “successfully installed”?

More pictures coming (can’t put them to the same message as a new user)

I have tried setting IP many many ways but connection is still failing. I also have been trying to use another router but it’s still not working. This another router is Huawei B525S-23A and this model can’t be set to bridged mode, is it a problem?

Also I’m not sure about my router setting, I tried to set static IP but not sure is it right?

Screenshot from 2023-01-28 19-51-01

Should this be “Connected”? And if so how I can do it?Screenshot from 2023-01-28 19-51-19

I think these are ok?

Should DHCP server be enabled or disabled?

VBox network adapter was set “wlp2s0f0” which is WIFI and then I started virtual machine and installed esphome to ESP32.

In HA web-UI ESP32 is “online” but doesn’t stay online. What IP adresses I now should put and is this the right way to do it: