Ha fresh install connection refused

I made a fresh install but cannot access my rpi the message in connection refused.
I have a rpi model 3b and follow the procedure ie install 64-bit version with the image loader. I try to access with homeassistant:8123. the ping is working
then I enable the WIFI and ssh and try again same message.
I can see the screen if i connect my TV but no keyboard
I can access with ssh. the date was wrong and the ip is correct, no error in boot.log. I have change the date with date -s command and reboot but still the problem.
I suspect a hardware problem since date is wrong.
what command can help ?
can I run some diags ?
Thanks for your help

If you are using the pi imager tool, then do not use the wifi or ssh settings in the bottom of the imager tool, these will not work and will stop HA from working. You need to connect with a cable to your LAN / Router for the install to work.

The wifi settings in the imager tool are for the pi os, or “normal” linux installs.

1 Like

ok solved. I have to take the take the right image in th PI image loader. I jump in the 64-bit os but I have to choose Other specific-purpose OS and then home assistant