HA & Frigate in a docker

hi all.

i’m swearing for 3 days and nights in a row know…
happy user for 3 years know, HA in a rPi4 with external ssd and recently a coral TPU usb.
always programmed and soldered my esp 8266 and 32’s.for ESPhome stuff

here is the thing…:

i want to have an external disk for my frigate data, after trying and trying with differs addons and workarrounds giving in that it has to be working with docker…

it’s the only way to get “freedom” to be able to hook up some external space/drive/volume for Frigate…

so i’m trying docker with al those seperate applications.

i have a HPE mini server, did an ubuntu install and a docker desktop install…
the test tortual worked…

trying to "Pull " the frigate imagine…
never did a pull before. tried for hours…
i have a docker account, did the login certification file ceremonie. all well
still no download…

oke deep brath, letting go…

tried with a homeassistant “image”
bam! direct downloading…
start RUN in docker, starting, but no port, so can’t connect to it…
googling my eyes crossed…
portainer seems to help. need to make a “config script” etc etc

oke portainer image pulling…check!

running portainer… another mounting to learn and configure…

my question:

is it so dam difficult to have a “all in one HA”( like i always had with mij rPI4) to connect an external drive for Frigate???

if i ever manage to get HA and Frigate working in a docker, then there are also al those other addon’s that have to be by docker isn’t it?
( node red, mosquitto and another 10…)

tried this?

yes that was another 1,5 day of frustration.
did a truenas install,
made an VM macine with al the specs,
did unpack the supervised image and uploaded it
in the truenas shell i copy/mounted the uploaded image onto the Zvol for the HA.
homeassistant worked, only the usb passthrough didn’t work (needed for the Coral TPU)
and at that point i didn’t check if i was able to mount a mirrored volume for the frigate…
just went to the docker experience…

What guide are you trying and what are trying to run in? Should just need to use docker compose, if a port isn’t working then did you have HA running in host mode?

Also, our frigate docs give a complete docker compose file: Installation | Frigate so should just need to have that and run docker compose up inside the directory that has that file. Happy to help more but need specifics on what issues you’re seeing and what your current config looks like

hi, thnx for your reply,

now i’m trying it on Debian11. following this guide:

installation Debian11 goes well.
only the part of getting the docker itself is painfull, in the vid he copy and paste and Voila!
(curl -fsSL get.docker.com | sh)
if i do that exactly the same i get errors about not finding files and packages…
" Executing docker install script, commit: 4f282167c425347a931ccfd95cc91fab041d414f

+ sh -c apt-get update -qq >/dev/null

+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null

+ sh -c mkdir -p /etc/apt/keyrings && chmod -R 0755 /etc/apt/keyrings

+ sh -c curl -fsSL “https://download.docker.com/linux/debian/gpg” | gpg --dearmor --yes -o /etc/apt/keyrings/docker.gpg

+ sh -c chmod a+r /etc/apt/keyrings/docker.gpg

+ sh -c echo “deb [arch=i386 signed-by=/etc/apt/keyrings/docker.gpg] Index of linux/debian/ bullseye stable” > /etc/apt/sources.list.d/docker.list

+ sh -c apt-get update -qq >/dev/null

+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq --no-install-recommends docker-ce docker-ce-cli containerd.io docker-compose-plugin >/dev/null

E: Package ‘docker-ce’ has no installation candidate

E: Package ‘docker-ce-cli’ has no installation candidate

E: Unable to locate package containerd.io

E: Couldn’t find any package by glob ‘containerd.io

E: Couldn’t find any package by regex ‘containerd.io

E: Unable to locate package docker-compose-plugin"

at this point i did so many tries that i’m about te format the disk and start allover with a
clean debian11 install

I would always just recommend using the docs from the thing you’re trying to download and not a video online as they often become out of date. Following Install the Compose plugin | Docker Documentation

all you’ll need to run is

sudo apt-get update
sudo apt-get install docker-compose-plugin

appreciate your time, for now i’m not there yet, just installing docker now. i see that docker desktop comes with compose automatically…

thnx for the link.

Gotcha, Install Docker Engine on Ubuntu | Docker Documentation should do it then

just a reboot after a first test (test docker101tutortial in docker-desktop) couldn’t open the generated webpage.
— port 80 was in use — (new debian install :slight_smile: got it working, now looking where to find the compose section, or is it a seperate programm/app …