I am a new HA user, so please feel free to correct me!

Having an issue with HACS on the Home Assistant, hoping someone may assist.
In short my issue is that HACS is successfully installed but there is no entity called HACS nor device.
As well once HACS is entered, it is blank only showing ‘about’

Can someone please review my process, maybe I made a mistake or there was is an issue with HACS

I am running HA Core on my raspberry pi device.

This is the tutorial I followed for the installation of HACS
Installation | HACS

For the installation, I entered my raspberry pi which has Linux installed, entered the terminal and switched from pi user to HA user

as the tutorial stated, I copied this code and pasted into the terminal

wget -q -O - https://install.hacs.xyz | bash -

Once HACS was installed, I entered my Home Assistant, checked the configuration validation (which was valid) and restarted the HA.

Now I tried both ways for configuring the HACS, both did not work

Standard configuration,

Cleared my browser cache and then added HACS through HA- integrations.
I agreed to all 4 terms and I was given a device code and entered it to https://github.com/login/device

I authorized HACS to have access to my GitHub account which was successful
Came back to HA clicked submit and HACS was added as an integration on my HA

However there was no entity nor device named HACS
HACS was added on my sidebar but once you enter it. everything was blank besides there being “about”
there were no ‘integrations’, ‘frontend’, ‘automation’ option.

Legacy Configuration (YAML)

I tried to configure the HACS through YAML
by entering my Github account and making personal access token
All tutorials said to just make the token without checking an boxes or setting an options

Once token was made and copied, I went into my configuration.yaml file through my terminal
and added the token as tutorial stated

  token: mytoken

Once checking in configuration validation and making sure all code was valid. I continued to restart the HA again.

HACS was not added in the integrations section of HA, if you try to add it, it will say “only one configuration of HACS is allowed”

HACS will be added on the sidebar but once you enter it there will only be the option of ‘about’
there was no ‘integrations’, ‘frontend’, ‘automation’ option


HA Core cannot use HACS. You need either the Home Assistant OS Image or install Home Assistant Supervised which is only supported on a Debian installation. I am currently running a Debian ( not Raspian) image with supervised on my Pi 3B+

This is not true…

OK, HACS will run on core.

When I left HA 2 years ago HACS was just starting and the available installation options were different.

Nope, HACS has always been for all installation types.
It’s just a custom integration

1 Like

HACS has always worked on all installations of HA afaik.

EDIT OK beaten to it by @ludeeus , and he should know.

1 Like

Give it an hour or so, it’s still starting up (Check Link to Info – My Home Assistant for current state)

You would think that right :joy:


i bloody hope so, otherwise were all stuffed

1 Like

I wasn’t able to enter the link you sent however, I will take your advice on giving it time. How long would you say is too long?

Also here are some screenshots to get a visual on what I mean

Screenshot (36)

Unless something in your log, no more than 2h

Hey Ludeeus!

Hacs is still now working but I have received a few error messages in logs.
I am not sure what it means :confused:

Logger: homeassistant.util.json
Source: util/json.py:32
First occurred: June 16, 2021, 4:51:53 PM (1 occurrences)
Last logged: June 16, 2021, 4:51:53 PM

Could not parse JSON content: /home/ha/.homeassistant/.storage/hacs.critical

Traceback (most recent call last):
  File "/srv/ha/lib/python3.8/site-packages/homeassistant/util/json.py", line 32, in load_json
    return json.loads(fdesc.read())  # type: ignore
  File "/usr/local/lib/python3.8/json/__init__.py", line 357, in loads
    return _default_decoder.decode(s)
  File "/usr/local/lib/python3.8/json/decoder.py", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/local/lib/python3.8/json/decoder.py", line 355, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 4 (char 3)

I have tried to investigate by going to /home/ha/.homeassistant/.storage/hacs.critical

but there was nothing in hacs.critical

Thank you in advance

That file has been corrupted, delete it.
and look into repacing your storage media, this will not be the last time.