HA HassIO without internet access

I would like to know if HA needs internet access to work properly.

When I boot it with internet access, it boots without any problem.
When I boot it without internet access, most of the times the system seems to boot, I can ping the machine (Rasp Pi), however I cannot access the HA web interface.

Is this an NTP problem? Maybe another? How can I solve this so I can have my HA working without internet access.

(bellow you can check my system configuration. I am just using mqtt and switches. I have no need to “sun related stuff” or others)

Thanks

System:

Supervisor
Version 2020.10.0
Operating System
HassOS 4.14
Add-ons
File editor, Mosquitto broker; Terminal&SSH; UniFi Controller

Yes. Home assistant needs to contact an NTP server on starting. You could run your own GPS backed local NTP server.

Thanks for your help.

Does it happens only when booting or HA tries/needs to connect from time to time?

Do you know if it is possible to “deactivate this need” of HA having to contact an NTP server?

Thanks

1 Like

I am using a raspberry pi to run hassio.io
Since I have a PC (windows 7) always running on the same network I decided to activate the built-in NTP server/service (IP: 192.168.1.5).

Configured HA NTP to synchronize with that machine in case other servers fail.
[Time]
NTP=time1.google.com time2.google.com time3.google.com
FallbackNTP=192.168.1.5

also tried to configure it as main NTP server (Does anyone sees any problem with this configuration?)

Tried by creating the “CONFIG/timesyncd.conf” file in the boot partition but it doesn’t seem to work.
Also tried using a CLI and editing directly the file “/etc/systemd/timesyncd.conf” . Neither “systemd” folder nor the “timesyncd.conf” existed, so I had to create both (Does anyone sees any problem with this? Maybe I am editing in the wrong place)

Thanks

In the meanwhile I found out that when I start HA without internet access only the container below starts…

796e9a0644b2 homeassistant/armv7-hassio-observer:2020.10.1 "/init" 3 days ago Up About a minute 0.0.0.0:4357->80/tcp hassio_observer