HA Headless Install no ssh or wifi

Hi, My rpi4 does not have a monitor so am trying to setup ha headless. I ran the rpi imager and set the empty ssh and wpa_supplicant.conf file in the root of the boot part on the sdhc but it does not connect to the wifi. I also tried adding the runfirst.sh file from the config.txt taken from a standard rpi debian image which works fine with the default 64 bit rpi image. Does HA require a different config? Does it not enable the wlan wifi interface or something like that? I also tried the rj45 port and while this does take an ip from the router dhcp ssh is not enabled. Thoughts ?

My thoughts: Don’t use wifi, use ethernet. You don’t have a TV you can plug it into? Start over, skip the ssh and wifi config and try connecting through a browser on dhcp ip / port 8123.

I wish I could be more help here, but when I set up headless Ubuntu (2020) and Debian (2023) installs I’ll be damned if I was able to log in on WiFi. My RP4 sits next to the router so I configured a static IP for eth0 (although logging into the router you can typically easily find its DHCP address) and futzed with it that way until I could get wlan0 operational… and if memory serves, this was much easier on Ubuntu than Debian. Best of luck.

Oh, and now that you mention it, the Debian image for RP4 is locked up tight. I couldn’t find a way to get ssh going at first boot, so I just spent some time on console getting that to work! Nothing like console text being sent to a 32" UHD monitor LOL