Home Assistant Community

HA image install Raspberry Pi - Constant Reboot

#1

Hello,

new to Raspberry Pi and Hass. In my very first setup, i followed the installation instructions

  1. Buy Raspberry Pi 3B+ kit, 32Gb SD card, and usb drive
  2. Download Hass.io image. unzip file
  3. Download balenaEtcher and flash the SD card with the image
  4. Setup USB drive with \CONFIG\network\ and ‘created my-network.txt’ for LAN setup with static IP
  5. Insert SD card and USB drive
  6. Make sure to have appropriate power cable plugged into outlet.
  7. Plug in Ethernet cable, monitor, and keyboard
  8. Boot

When I boot, the Pi continues in a constant reboot cycle…

#2

Error messages on the monitor?

#3

Are you seeing something like this?
Net: No ethernet found.
starting USB…
USB0: scanning bus 0 for devices… 5 USB Device(s)
Hit any key to stop autoboot:

This happened to me with a Raspberry Pi 3B and 3B+ recently using hassio flashed to a 32gb sd card. Didn’t matter if I set a static IP or not. It would just keep rebooting and rebooting. I tried both 32bit and 64bit Hassio images.

#4

it is hard to make out. the screen runs through text in about 2 seconds and then restarts.
hit any key to stop autoboot:
a quick flash of a bunch of text

The end looks like it says
mmc write failed
0 blocks written : ERROR
loading Kernetl
Warning at drivers/mmc (bunch of text)

#5

I took a video of the screen while booting and then captured a image.

#6

Yes, I have watched the boot sequence several times and i see those keywords flash on the screen.

#7

Hi, i have the same problem, do you have a solution?

#8

No I was not able to find help or resolve. I gave up on the RasPi and built a virtual machine. Then I gave up on the whole project as it’s not very usable with my devices

Amazon Echo x 5
Jinvoo smart plugs x 10
Chamberlain MyQ garage
Arlo Cameras x 10
Yamaha Theater Receiver
Apple TV x 5
Roku x 4
Ring Doorbell

The only device type I was able to connect was the Roku and it gave me remote control capability. Zero automation.

This isn’t worth all the work

#9

OK, thanks for your answer.

#10

Hi all.
I am new to , and having this Same problem.
Annybody solved iT for a raspberry

Mvg

Bjorn