HA instance not loading on outside network

Hi All,

I’ve done a bit of searching and can’t seem to find information on the exact problem I have.

I’ve got my Hass.io setup with the Duckdns addon so that I can access it from outside the network.
I recently moved house and changed ISP. Before this I had no issue connecting to my HA from anywhere.
Now, after the move, I can only access it from the same network my HA is, or using mobile data from my phone. When I try to access it from my laptop on other networks (I’ve tried two, and these are networks I could access it from previously) I just get the HA logo and loading data, then a ‘Unable to connect to Home Assistant.’

This makes me think its not port forwarding issue, as I am getting to the HA. It’s just not loading so I can log in.

Any help, or some pointers would be helpful, as this has me a bit stumped.
And yes, I have power cycled the unit a couple of times with no change.

Do you have trusted networks specified?

Did you change routers when you changed ISPs?

Tom_l: Do you mean the home network or external networks?

RyanRayNeff: I didn’t change the router at home, just the modem. All my network settings stayed the same, as I run the modem in bridged mode.

Be sure to rest the connection after clearing your cache or using private/incognito mode. HA is heavily cached and will appear to be loading the HA page when no actual connection has been made.

That being said, trace the whole path, confirm ducks a is being updated with your new IP correctly, check your port forward settings, check your ha settings.

I would remove any security you have in place and reinstate them one by one if it connects without them in place.

Yes, it might be tired,


Still having issues with this.

I ended up wiping my whole install and starting from scratch. I also factory reset my modem and router, and set them both up again.

I’m also having issues with updating Home Assistant or installing add-ons.
The error im getting is: "500 Server Error: Internal Server Error ("error parsing HTTP 408 response body: invalid character ‘<’ looking for beginning of value: “<'html><'body><‘h1>408 Request Time-out<’/h1>\nYour browser didn’t send a complete request in time.”
From my searching this is a DNS issue, so these may be linked?

I have not setup any trusted networks, and can get to my Home Assistant from my phone using LTE with no issues. Owntracks works fine, as does Google Assistant. Yet my laptop can’t access from anywhere but at home, and my mobile can’t access from other wifi networks.