HA is not showing up on the local network after upgrade to 2023.3

HA newbie here to make the long story short. Everything was running fine until yesterday when I noticed that there was an upgrade available to 2023.3. I decided to go ahead. But then after the upgrade I have not been able to access HA via the port addess website. The IP still remaind the same and when connecting the PI to a monitor I see that I still have the same IP address (which shows up) but still no connection.

I get this when trying to connect.

I’ve removed/reset the DNS settings so I’m hoping that’s been now taken out of the equation but still no luck. But when I check the pi to the monitor it still shows as connected.

Does anyone have any ideas? I’m hoping to avoid a complete reset… HA did take a backup… but I’m hopeing it’s just local on the sd card so I can get it off that

The upgrade can take time on sdcard.
Try to access in ssh your HA instance and check logs
You can try this http://homeassistant.local:4357/ (use your local dns or ip, I don’t know your configuration) to access HA observer.

So the HA observer gives a greenlight (dns is now removed so just using my ip now)

The upgrade was triggered yesterday and I left it over the night so I only checked it this morning and it showed up as down and sadly I only set up the ssh on frontend. I just tried to use it now but it seems to not be connecting… I’ll try to get a log via a monitor

Normaly everything is ok on HA. Are you sure you put the correct ip:port to connect to ?

For me, it seems just an small issue about URL to access it.

So I double tripple checked the IP I was using still no luck and then rather than the IP I used http://homeassistant.local:8123 - sadly still no luck…

Trying to run the log now… see what pops up

If you get the observer page (via ip or dns), it’s the correct address. Only the port to be updated. it’s 8123 in local if you not change the default setup. Put also http:// in front because browser can try in https.

to see if the port is open try a telnet on it: example
telnet 8123
Connected to

Apologies I guess the screenshot was misleading… I did enter the address with http:// in front Firefox just removes that each time the page loads. As for the telnet (not possible as I’m on mac) but a similar terminal remote here’s a similar test

Also on the CLI I ran “ha network info” to ensure that the IP was matching so it’s definitely the right one.

Furthermore on the CLI I have been able to run the logs command… though cannot scroll… however it the part of the log I can see is defintely showing errors related to files not found for “python3.10” and some timeouts…

Wow, this is new to me. Thank you!

I’m having a hard time searching for this feature. Any idea where it might be documented?

1 Like

Haha it was for me as well… then when I checked the CLI… under “frontend”

If you have access to cli, you just be able to look in details and find the root cause.

if you can’t scroll use for instance: ha supervisor info | more

Well, that makes me feel better about not finding any documentation (outside of an announcement blog) on the home-assistant.io site.

This seems like such a handy tool, you’d think there would be a proper write-up.

What if you use http://< IP-address-of-your-HA >:8123

BTW: it’s not necessary to hide the LAN-IP address of your HA: many users here use the same LOCAL subnet;

1 Like

even if many users use the same local or different, it’s local … so :slight_smile:

Yeah good point… I was just being extra cautions I guess…

I did try http://< IP-address-of-your-HA >:8123 this as well to no fortune

Do you get a reply when you ping the IP?

Thanks I’ll try this… it seems that I have an issue with the core… for some reason the showing various… sadly scroll did not work even via the supervisor that you had provided

With cli, just reboot or shutdown with power off/on (when led is stop blinking) and try again :slight_smile:

Yes pinging the IP and also the port seems to be fine

Pinging the Port:

Pinging the Host:

Have you gone into your config directory to look at the homeassistant.log file contents to see if there are any errors there?