HA July 2022 running in Container Station on QNAP NAS - Failing to start

Hi - I’ve tried to install the July 2022 release(s) into my QNAP container station, this has been working OK until this release, which will not start. Has anyone successfully upgraded to July XX releases using this setup?

I have noticed that the environment config has changed and WHEELS_LINK is now ‘Home Assistant Wheels’ (rather than https://wheels.home-assistant.io/alpine-3.12/armhf) is this a coincidence?

I’m using the Docker Hub images.

Not sure where to start looking for the issue with this one TBH, all upgrades until now have been flawless.

2 Likes

Hi, I share the same issue here. I have had Home Assistant Core running in docker on QNAP (arm processor) for two years, and it has been working well until 2022.6.7, then since 2022.7 it is not starting anymore.

Let me say that I have always had to issue the command python3 -m homeassistant --config /config otherwise the container will stop immediately (this is since forever…).

As a result, right now I can only run the 2022.6.7 version, and the subsequent ones will not work for me. I have tried with 2022.7 and 2022.8, but none of these start. So I reverted to 2022.6.7, which seems to be the last one starting and running correctly.

Any way to solve this?
Thanks

Glad it’s not just me - I’ve bitten the bullet and moved away from QNAP, I’ve built out a Raspberry PI version and so far this is proving much more reliable.

I felt it was only a matter of time before I was completely stuck if I stayed reliant on QNAP Container Station and the relatively few people that have this config.