Home Assistant Community

HA Lovelace 0.92.2 Not working custom components "Custom element doesn't exist: tracker-card."

#1

Hi all.
Some info for troubleshooting:

  • Installed the custom card following the instructions on https://github.com/custom-cards/tracker-card
  • Downloaded the file from the RAW view and uploaded them.
  • Called the service “custom_updater.check_all”
  • Cleared cache and rebooted HA

Raw config editor:

title: Home Assistant
resources:
  - url: /customcards/github/custom-cards/tracker-card.js?track=true
    type: module

configuration.yaml

custom_updater:
  track:
    - components
    - python_scripts
  component_urls:
    - https://raw.githubusercontent.com/pnbruckner/homeassistant-config/master/custom_components.json
  python_script_urls:
    - https://raw.githubusercontent.com/pnbruckner/homeassistant-config/master/python_scripts.json

File location:
/config/customcards/github/custom-cards/tracker-card.js

Custom card:
type: ‘custom:tracker-card’

2019-05-15%2009_50_06-Home%20Assistant

System Health

|arch|armv7l|
| --- | --- |
|dev|false|
|docker|true|
|hassio|true|
|os_name|Linux|
|python_version|3.7.3|
|timezone|Europe/Amsterdam|
|version|0.92.2|
|virtualenv|false|

### Lovelace

|mode|storage|
| --- | --- |
|resources|2|
|views|5|
#2

Did you also install the prerequisite custom_updater?

#3

Yes installed!
The tracker-card worked ones for a short while, and then i added another custom component and it stopped working. Rolled it back but could not get it to work again.

#4

Which browser?
In Chrome, try F12 and right click on the refresh button select empty cache and hard reload

#5

Sadly not the solution.
Tried it couple of times without luck.
Other browsers also nu luck.

#6

I have

  - url: /customcards/custom-lovelace/tracker-card/tracker-card.js?track=true
    type: js

I have type: js not type: module

I know that in the instruction is set to module, you can try…

BTW, I have downloaded and have it locally in /config/www/custom-lovelace/tracker-card/tracker-card.js

#7

Stupid question… the file location is

/config/www/github/custom-cards/tracker-card.js

Right? customcards and local are not real folders but links to www

#8

The physical location is that, but when defining in the yaml file you have to set /customcards that is the same as /config/www

I have now tried using what specified in the instruction, executed custom_updater.check_all from the Services panel and I have it works.

#9

Moved my file to /config/www/custom-lovelace/tracker-card/tracker-card.js

Changed config to:
resources:

  • url: /customcards/custom-lovelace/tracker-card/tracker-card.js?track=true

testing

#10

This is the config now and file location

2019-05-15%2011_54_27-Home%20Assistant

Stil the same error, with a hard refresh and custom_updater.check_all and reboot :frowning:

#11

Is it the same to have

- type: js
  url: ......

instead of

- url: .....
  type: js

??

#12

Yes woody - makes no difference.

#13

You definitely RESTARTED (don’t EVER Reboot) AFTER you created the www folder?

#14

I created the www folder a lot of time ago, so now I’ve just made the changes I told you before, I’ve saved the ui-lovelace.yaml file and refreshed the browser.

Do you have any other messages in the HA log that can rely to this issue?

#15

Yes restarted:) not rebooted hehe.
Furthermore no error’s to indicate whats wrong…

#16

I might have had this same annoying issue. I’ve solved it by appending &v=2 to the url in the Lovelace config after confirming that custom-updated has downloaded the file.

#18

How do you mean that?
Do you have a example of what you did?

#19

I go into the lovelace raw config editor and enter, for example, this:

- type: module
  url: /customcards/github/benct/multiple-entity-row.js?track=true

Then I go use the custom-updater and have it check and grab the multiple-entity-row js file. I confirm it is in my /config/www folder, then I go back in and modify the lovelace config to:

- type: module
  url: /customcards/github/benct/multiple-entity-row.js?track=true&v=1

I refresh the hass UI and then it starts working.

#20

how do you confirming that custom-updated has downloaded the file?

#21

After calling the custom_updater service it gets automatically pulled in to the /config/www folder: