HA mysensors DHT problem


I am trying to put together my first Humidity sensor (using mysensors.org) and checking its readings by HA. I think I am completely lost and confused.

I have my serial gateway and my sensor both up and running;

But I am not sure if I need to introduce my sensor to my HA by editing my “configuration.yaml” ? Or HA should discover it automatically ?

When I initialise the HA, I get an error saying;
16-09-08 22:01:51 homeassistant.bootstrap: Not initializing sensor.dht because could not install dependency http://github.com/adafruit/Adafruit_Python_DHT/archive/310c59b0293354d07d94375f1365f7b9b9110c7d.zip#Adafruit_DHT==1.3.0

I tried to install the missing dependency, but still I get the same error …

I would really appreciate any help.

Sorry, not familiar with a MySensors setup. But if it seems that you need to setup MySensors and a sensor. Not need for an DHT sensor entry in your configuration.yaml file.

@fabaff, Well, thats my understanding as well. One arduino is running SerialGW and another Arduino is reporting the sensor values… Also I did not include DHT sensor entry in my configuration.yaml file at all …

Well, unfortunately you have to wait for @martinhjelmare. He knows MySensors pretty well.

I am looking forward to his help then :slight_smile: Thank you for your help @fabaff

Please post HA log after start and include all mysensors related lines. The serial log from the gateway looks good.

Hi Martin,

I installed the missing dependency manually again and restarted my computer. Then when I started the HA, the error was gone ! So I guess one complete restart has helped somehow.

When the HA started, it initially recognised a sensor connected, but it was showing it as a light sensor … so I tried to tweak it in developer tool ! And I completely lost it … :confused:

THis is the log of the HA right now:

This is the MYSController image of my setup;

[UPDATE]: Martin, I did another restart of the system, and now the HA found the sensor again but it is still reporting it as a light sensor:

the HA log file:

My apologies guys, I keep updating my post. After trying to restart the sensor, and the GW and finally deleting the old mysensors.json and letting HA to create a new one, I think I managed make a step forward.

Now my HA’s State page looks like:

However, I still get an error related to malformed XML;

16-09-09 10:49:54 netdisco.ssdp: Found malformed XML at 
16-09-09 10:49:54 netdisco.ssdp: Found malformed XML at <?xml version="1.0" encoding="utf-8"?><root xmlns="urn:schemas-upnp-org:device-1-0" xmlns:dlna="urn:schemas-dlna-org:device-1-0">

Should I be concerned about it ? If yes, How can I fix it.

If you set node ids manually and reuse node ids between firmware updates and different node types you have to edit or delete the persistence file. Otherwise the previous node will block the new node from changing the entity.

I don’t know about the XML error. It’s related to the discovery component it seems.

It helps when troubleshooting to set log level to debug for the component and dependency under question. See the logger component.

Deleting the persistence file certainly helped. Thanks Martin.