HA not available in iOS notifications section

Tags: #<Tag:0x00007f739eac8a50>

You are correct, ios will still work, however new users or people that didn’t use 1.5.1 in the past might not have this. I for one don’t have it I believe as I haven’t used the 1.5.1 app ever since 2.0 was in beta.

Also I have to mention that I made that specific post a few months back when it was still in beta. You don’t have to do the fake notification, but I believe it is also mentioned that you should only attempt that if it isn’t working (and in the beta period this would often be the case when using actionable notifications for the first time with the “old” ios config)

The only reason I share this again because this method has worked 100% of the time for me and all devices I have set up in the past.

When coming from beta, I will still suggest to remove ALL integrations regarding the mobile app in HA, restart HA and then reinstall the app and start the onboarding process again. (Then after onboarding restart HA while the app is open so it can register the mobile_app notify service, which is not there after onboarding).

Ofc a lot has changed regarding the app, but following these steps should theoretically make it work unless there are other problems.

Edit: still, it wouldn’t hurt to try :rofl::joy:. Maybe it will solve his problem. Sometimes these kind of things are found on such simple solutions. But like I mentioned I can’t guarantee that it works for him. It worked for virtually everyone I had set it up for in the past so who knows.

That’s correct. It doesn’t seem that the operating system knows that the app is registered to receive push notifications. So although the app is acknowledging receipt there is no option in iOS to allow push for HA Companion.

cool.
all I can say is I’ve been using 1.5 and beta parallel for a very long time (used them to each control another HA instance I have running, which was very handy) but also to check the same instances and see the differences. (switching between servers was way easier on the 1.5 app, still haven’t found my way in doing so in the 2.0 version…I believe I’ve read this is intentional unfortunately)

Installing the 2.0 app and registering it with the HA instance sufficed to get it all working as expected, with the aforementioned sensor-naming ‘issues’ that had to be tackled.

other than that, happy camper.

just remember to update the settings in the app after changing anything in the code, it is what most people forget…

Noticed another post where AlRos is having the exact issue that I am.

have you deleted all mobile_app referecense in the .storage files already. And do a restart to let the registry rewrite all details afresh?

also, and this might sound silly, but when you check settings in your iPhone and scroll to notifications, don’t you see a homeassistant icon and all available options there?

I have not tried deleting mobile_app references. When I go to setting , notifications section in iOS (iPhone) there is no homeassistant icon. If I scroll all the way down to the home assistant app under settings there are only 4 settings, location which is set to always, siri & search, background app refresh which is on and cellular data which is on. No notification entry there either.

thats odd, it should really be there…Ill try and post from my iPhone after hitting reply here

this is different also here:

note this is an iPhone 11 pro with iOS 13.2.3

I was using actionable notifications prior to the 2.0 upgrade. I have many apps where push is working so I don’t believe it is an iOS issue.

well, out if ideas then, other than checking the naming. As said, I’ve renamed my ‘old’ device_trackers (with the suffix ‘_ios’) so I am positively certain the HA server sees the difference between old and new.

OMG, I’m an idiot. This doesn’t seem intuitive to me but I uninstalled the home companion app from my phone. When I reinstalled it has the three options for location, pedo and notification. They have an allow button next to them. I didn’t realize the buttons were clickable. When I clicked the notification button it trigger iOS and now I see it in my notifications section.

yes indeed. Must confess I agree with the ‘unobtrusiveness’ of these buttons…:wink:
same goes for the allow buttons on movement etc etc. Just click everything :wink:

So basically the first 3 steps of that guide I posted already fixed your issue. It’s ok for not having tried my suggestion, but I was partially right though :rofl::joy:.

Anyways great to hear it is working again!

Hey Jim, not really. I had already followed your guide. I was not selecting the enable buttons because I thought they were indicators showing that it was set to enable. You might want to update your guide to indicate that the notification button must be selected before proceeding. For some reason the location button does not have to be selected as you can go into the iOS location settings and turn it on. But if you do not select the notification enable button you can not go back to the notification section in iOS and turn it on. Personally I think the HA app should attempt to register itself for notification settings so at least the user could decide to turn it on later without having to reinstall the app.

1 Like

Thanks for clarifying, yes I should update the guide. It was actually only meant for the beta version as I did not expect these problems to persist in the final version.

I will add your suggestions. (Sorry if I sounded harsh, wasn’t my intention).

I am already glad that you have worked it out, because lets be honest, we can’t live without HA anymore :rofl::joy:. Thanks for your solution.

Yep totally committed. I have been an ISY user for 10 years. The only thing it is doing now is acting as the inter-medium between HA and my Insteon switches.

Guys i would preciate if you can help with my notify.mobile_app_your_iphone issue. I read almost all the posts and did the steps what Jimz011 explaned like 5 times.
I dont get the notify.mobile_app_your_iphone.

The first thing you should check is to run (not walk) to your config.yaml file. Make sure you have the following listed:

iOS:

mobile_app:

If not, add them.

Download the iOS app, the rest is self explanatory. Pay special attention to the permissions, enable all of them to be safe. Permit notifications.

Additionally, check your regular iOS settings and look under Home Assistant. (Notifications should be enabled, but it doesn’t hurt to check).

Once that’s done, log into the app and go directly to Developer Tools/Services, and something like “notify_mobile_phone” should be in there.

Edited for typos.

1 Like

You need to restart HA after completing setup of the App on your phone. And then if it’s still not there, restart it again.

1 Like

Yeah I totally agree with this. When running the setup ‘wizard’ the buttons indicate ‘Allow’ which I inadvertently took as ‘its allowed’ rather than actually needing to click on it.

Maybe if the wording could be changed to ‘setup’ ? :grimacing:

Also, if you don’t allow these during the setup (can really only confirm for notifications) there is no actual way to enable them later other than removing/reconfiguring it again. Even the notifications menu in ‘App configuration’ does not indicate if it’s enabled for iOS

1 Like

I am getting this problem again where HA is not available in the IOS notifications setting.
In my case, I deleted the app because I my notifications stopped working–getting an error [homeassistant.components.mobile_app.notify] Requested entity was not found. (it was working fine before)

I decided to try to delete the IOS integration and the app and try to reconfigure to get the notification working again. But now when I run the newly installed app, it doesn’t give me an option to allow notifications like it has in the past. It just runs the app. When I go to look in the iOS notifications settings, Home assistant isn’t listed.

Any ideas how to reset this properly to get the prompts for notifications when the app is run?