HA not displaying Community Add-ons


I’m running on the latest, at the time of writing, which is
Core 2024.4.2
Supervisor 2024.04.0
OS 12.1

For some reason, the add-on store only shows the official add-ons and a couple external repositories that I added manually, but does not show community add-ons.
In particular, I was trying to install AdGuard, but the add-on is not present in the store.

I obviously tried to manually add the community store repo, but HA says
Can’t add GitHub - hassio-addons/repository: Home Assistant Community Add-ons, already in the store

This is weird because I had it up to some time ago (although I can’t remember until when precisely)

The issue happens regardless of the device I’m using, but I still tried to clear the browser cache, which didn’t work.
Rebooting the whole RPi didn’t work either.

I can try a fresh install, but wanted to see if anyone had any ideas before I do that.

The community add-ons that I installed before the community repo disappeared work as normal

Are they getting updates though?

It could be a DNS issue. Check your DNS settings in Settings → System → Network.

Another thing to try is to put a trailing / at the end of the repository link, so this:


Instead of this:

1 Like

You’re awesome.

The trailing / actually fixed it, thank you!

1 Like

It’s a bit of a dirty work around to get past the duplicate repository detection.

We still don’t know why this happens. And it happens to quite a few people.

It’s probably not a DNS issue as that work around should resolve to the same IP address.

The addition of / did the job - woohoo!!