HA not finding emby server


I followed the simple instructions for connecting my local emby server to HA’s configuration file, but when I do the check it tells me “Configuration invalid.” and “Platform error media_player.emby-server - Integration “emby-server” not found.”

Not sure what I am doing wrong. This is the script I had to enter according to the manual.

platform: emby-server
api_key: xxxxxxxxxxxxxxxx

HA is running on a proxmox VM and has working internet connection and can see my other local machines and devices. Any ideas?

Thanks for any assistance.

Your config should read "platform: emby" not "platform: emby-server".
Also you did not specify the port used where your emby server can be reached:

    - platform: emby
      ssl: False
      port: 8096
      api_key: xxxxxxxxxxxxxxxx

Port 8096 is emby server’s default port for no SSL and port 8920 for SSL connections . Please verify which port your emby server listens on. Also check whether SSL is used (True) or not (False).

Some more information here.

Thanks for pointing this out! The confusion from my end was that the documentation only shows the API key to be required but not the port and ssl settings. :slight_smile:

So now that I have it integrated, whats next? I go to the lovelace ui and add a media-player. but than how to configure. I see many entities with the name Media_player.emby_[xxxx]. When I select for example media_player.emby_emby nothing happens. I just see a media player interface that doesn’t do anything and is not able to select the library.

Sorry for my confusion.

Agreed, the integration is somehow disappointing. There is no such thing as selecting media from the library etc. I use it just for having a card in Lovelace. If Emby is running on a TV/Box etc. it shows what is running and the only thing one can do ist ff, fr, stop and pause. Not really much.

Maybe I am missing something? Couldn’t find more though.

Thanks for bringing this to my attention. Pity that this is the only thing we can do with it. Hopefully in the near future more will be possible.

The destination device should be setup as a media player, then setup the emby server as a DLNA service as an integration. The DLNA server can then be used as the media source.

Sorry for my very late response! I had not seen it. :slight_smile: Great tip!

I tried setting it up but must be missing something.

I added emby as new DLNA device:

Screen Shot 2023-01-21 at 16.06.44

Than went to dashboard and added the media player but can only find the Emby DLNA grayed out. So cant select it.

Screen Shot 2023-01-21 at 16.07.28

Any idea what I did wrong, or am missing?

Have a nice weekend.

Add a target device, and then use the browse media button and select the Emby dlna server to browse.

Thanks for the reply!
Sorry for my stupidity here. Add “target device”? I dont follow this step. confused. :slight_smile: