HA not working on Pi3 B+ after clean install


I just purchaced an rPi3 B+ for HA today.
I followed all the instructions to the teeth while installing Hassbian, but I still can’t connect to IP:8123
I tried WiFi, tried wired, but the resoults are the same. After boot, the system does not seem to download anything, after like 30 secs it prompts me for user/pass and thats it.
It is stuck on this screen:
Google Photos

Raspbian works well, I have a 64 GB Sandisk Extreme SD card, and an official adapter, so HW should not be an issue. Tried to do the install process 3-4 times, but same result.

Any advice?

I tried manual install on top of Raspbian Lite. I can’t get python3-venv to install.

"Package python3-venv is not available, but is refered to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source.

E: Package ‘python3-venv’ has no installation candidate"

OK. This is strange as hell.
After switching to WiFi (wired was 100% working as well), I was logging out with exit.
After exit I tried sudo apt-get install python3-venv again. It worked.
What the actual hell!?

I have the same problem and couldn’t get it to work too, and I am a first timer so can’t offer much insights. Would like to know if you could get it to work.


Honestly, I just did what I mentioned above. Installed Raspbian Lite, then I just kept trying with python3-venv install until it worked somehow. Still no clue as to how, except for the info mentioned in post 3. :confused: