HA on Synology (Docker), HACS cannot be installed

Hi team
I searched the community and read hundreds of websites - still, no progress.
As I’ve learned, I need to install HACS to install card-mod.
Now, the instructions about that are fine.
Still: Seems like my DSM Version on Synology has 7Zip (7z) installed, but no unzip. And the installation of HACS requires unzip to run.
So, my question is:

  1. Is there a workaround to install HACS in my Docker instance on my Synology?
  2. Or do you know a way how to install unzip on Synology.
    Even trying some integration of unzip through an application community for Synology did not work… Meanwhile, it seems that even installing package updates on my Synology doesn’t work anymore.

Thanks for helping me out with either 1. or 2. :woozy_face:

I’m guessing that your Synology isn’t a “plus” model, because I borked my own “j” model the same way trying to force packages to install that weren’t meant for it.

Assuming that it’s a “plus” model, you should really be installing the full supervised HAOS distribution under Synology VMM using the HAOS VMware .ova file…

When you install HACS it is inside the HA environment which will have unzip available.

So where/how did you try to install it then?

When using docker, the application inside the docker image/container relies on the host OS and kernel and installed packages to function. If one is missing from the OS, it will not be able to be used by the docker container. That is what’s going on here, unzip is not installed on the host therefore not available for HA to install HACS.

OP, maybe go the route of HAOS in a VMM on your Synology as suggested. Personally I have never run into issues like this and running docker, but my Synology is a “plus” model.

1 Like

The docker runs its own OS but I am not a specialist so will not try to prove you wrong on your statements…however :slight_smile: My 218+ does not have unzip too and lo and behold, within the docker container there is…unzip

I have HA running in Docker on a Synology DS220+ (DSM 6.2.4) - no 7-zip and no problem. Perhaps your issue is something else.

Is it even possible to have 7-Zip & not have the ability to both zip & unzip??

Pending @Coffeejunky responding, zip/unzip is not required. Following instructions is required.

As this is a docker based install of HA then the instructions are here Download | HACS

Note that you need to click on the tab “container” to see the correct instructions.

As the instructions are to do this within the docker container, the script will have access to the executables within the container, which includes unzip. 7-zip is likely irrelevant, that is a different program.

If Synology is so retarded as to not give you command line access to docker, install portainer, it will give you access inside any docker container.

It can …

I would also not use HA on a Synology host as it throws errors when you need to use a zigbee usb device. Something about drivers. It’s been a while but I think it was about being not signed.

This is a becomming a deviating discussion as also Syno can (!) work with zigbee…but… as the OP has not reported back I will diconnect as of now.

Well - actually it’s a 220+ - but I will follow your advice and just installed the VMM environment…

1 Like

sorry :slight_smile: 2 kids, moved to new house, job… there’s not so much time left to sit in front of my PC. Will follow the advices I received.
Well - I assume I have a slight misunderstanding (sorry - my coding history ended mit .NET 2.0 and first releases of PowerShell - not so much about Linux, Unix & Co…):

I run SSH against my Synology (which is a 220+)
In this SSH session, I run the HACS install (download + bash execution) script
this throws the error of unzip not being installed.

Just guessing (sorry again - I’m starter and looking for the environment to be ready to dig deeper into the overall topic): do I need to SSH against the docker instance of HA itself and run the script there? confused

hm, I run an SSH against my Synology (ssh user@IP), then execute the script.
As written below: no clue how to SSH my Docker instance of HA…

This is what I get as I run the script from ssh:

Via your docker manager you can go into the running container and then select Terminal, from there you should execute the script

You clearly didn’t read the instructions that I specifically pointed you to. I don’t see the command that the instructions give you.

Specifically, seeing you can’t read (wth do I think you’ll read this when I am simply retyping something you have already pointed to)

docker exec -it homeassistant bash

ok - that helped. Managed to get the download running and the installation works now. So many thanks!

1 Like