HA on Ubuntu: Sonoff Zigbee 3 USB problem

I can´t get my Sonoff radio to work.
This is my first step into the great world of home automation and linux.
Please be gentle, i am a noob.

Laptop: i5-4310U, 8GBRam, 250GB HD, hd Graphics 4400.
Ubuntu 20.04

Instaled HA via Snap
Localhost:8123

New device discorverd
Sonoff Zigbee 3.0 USB Dong - /dev/serial/by-id/…

Zigbee Home Automation
Do you want to set up Sonoff…

Failed to probe the device.

Lsusb
Bus 001 Device 003: ID 10c4:ea60 Silicon Laps CP210x UART Briged

usb-devices
T: Bus=01 Lev:02 Prnt=02 Port=01 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=10c4 ProdID=ea60 Rev=01.00
S: Manufacturer=ITead
S: Product=Sonoff Zigbee 3.0 USB Dongle Plus
S: SerialNumber: xxxxxxxxxx
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I: If#=0x0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=cp210x

Driver
Lib/modules/5.15.0-43-generic/kernel/drivers/usb/serial/cp210x.ko

/Jan

This is probably where the problem is. The snap package very likely is managed by someone else, and not by HA. So maybe there is something else or configured differently? What is the HA version you got via snap?

I would follow the official install guide instead. You have options on various supported install methods, and snap is not one of those.

And from what I read here, would recommend you:

  • either setup a VM hypervisor on your ubuntu, and then do HAOS install, and then passthrough USB to your HAOS VM.
  • or, if you are planning to dedicated the laptop to HA, maybe install HAOS directly to your laptop. This way the zigbee usb thing should be plug and play, since the driver is already there.

EDIT: I forgot the link, and now added.

Ha Core 2022.6.7

Thanks, I will try one of your suggestions.

Hi K8gg.

I did had the same issue with snap under ubuntu 22.04 install on an old machine. . And as you must have figure since snap work in sandbox mode it cannot access the sonoff dongle on /dev/tt0 . So my only choice is to REMOVE snap HA. And tthe success installation road map I followed is this:

1- go to Installation - Home Assistant and select Generic x86-64 - Home Assistant

2- Then skip the first few step and go where it says Install Home Assistant Core near the bottom of the procedure.

3- Use terminal and Install dependencies with command line provided in the text.
I had difficulty in this step because some dependencies did not install.
Checking the error message I did add the recommended package so that repeating this command worked. It might be different for you so check the error is the key.

4- Create an account
I had difficutly with the following step mainly because the groups dont exist in ubuntu 22.04 . Only need to create the three groups .

"sudo useradd -rm homeassistant -G dialout,gpio,i2c ¨

5- Create the virtual environment

6- And lastly run hass

It took a while for the hass to come back. I finally realized that it was the server running accessible on http://localhost:8123. or on my local wifi as http://X.X.X.X:8123 (replace X.X.X.X with your machines’ IP address).

I plug the sonoff dungle and restarted the machine then HASS server in terminal as follow:.

sudo -u homeassistant -H -s
cd /srv/homeassistant
source bin/activate
hass

Then as explained by sonoff for the zbdongle-p here https://sonoff.tech/product-review/sonoff-zigbee-3-0-usb-dongle-plus-tutorials/ .  Sonoff Zigbee 3.0 USB Dong - /dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_U appeared after selecting ZHA . The  I selected  ZNP for configuration. 

The first device I added was a sonoff ZBmini switch it appeared as soon I pressed the configuration button. 

The second device was a sonoff  SNZB-03 motion sensor . It did not pop out. So first go to setting/integration and get  the ZHA device addition. A window appears waiting for pairing.  Then press the pairing mode with your sensor close to where you want to install it. So that the newly zigbee coordinator you just install find the best  route to reach it. 

Hope it helps
GiMiSa

Sorry but new users cannot post more then two http links so excuse the work around in formatting to give you sonoff link references.