HA OS - Configuration.yaml files - not being used?

This is a real newbie question. All over the doco, forums, and web are discussions on editing the configuration.yaml file and other .yaml files to do specific things.

I am running a HA OS, with the latest updates (Dec 21), and have added a good number of integrations throught the UI. I wanted to see what these looked like in the .yaml files. On HAOS the yaml files are supposed to be in the /config directory (and they are when I look using the Terminal addon), but the configuration.yaml file never changes, and does not contain anything like what the documentation regularly suggests it should.

After doing some looking around, I did find the “normal” content of the .yaml files, but it is in the /config/.storage/ directory in a series of files called core.config, core.config_entries etc. Does this just mean the documentation is out of date, or is there something going on I dont understand?

For a quick example, here is the entire content of configuration.yaml in the /config directory:

The typical configuration.yaml values for say my Sonoff Zigbee Stick are in the core.config_entries file:

Mostly, what I am looking to do is add some custom components (integrations), and I need to be clear where to put the files so that HA can find them and allow me to install the integration. But if I cant find the basic .yaml files, I dont think I will have much luck with custom components (and yes, I did try, and no joy yet).

Using the Terminal addon, I created the folder custom_components in the /config directory, and placed a custom component there (GitHub - CharlesGillanders/homeassistant-alphaESS: Monitor your energy generation, storage, and usage data using an unofficial API from Alpha ESS), and restarted HA and then the host, with no joy.

Can anyone point out where to look to find out how to do this using the current toolset (HA OS), or point out what I am doing wrong?

Apologies for the newbie questions…

The latter.

As you have found, integrations added via the UI are stored as json in the hidden .storage folder. This is not supposed to be user editable.

There are still many integrations that can not be set up via the UI and require you to write a few short lines of YAML either in your configuration.yaml file or other files that configuration.yaml points to by using !include statements.

To do this follow the instructions of the third party integrations. In the case that you have identified above for homeassistant-alphaESS, this particlar integration can be set up from the UI but requires a bit of set up first.

You have indicated you have done steps 1 though 3 (the host restart was not required, only HA). Now you need to do step 4. Go to the Configuration / Devices & Services page, in the lower right hand corner you will see an “Add Integration” button. Click it and search for Alpha ESS. Add it and follow any setup requirements.

1 Like


Thanks. The doco never seems to mention that the configuration is stored in these JSON files, it seems to imply everything is in the configuration files. Anyway good to know that both are in use, and not to edit the JSON ones.

For the second part, I had tried on a number of occasions to execute step 4, but the integration never showed up, which I why I started asking myself if I was storing the files in the right place. That led me back to looking to see if the configurations where where the doco indicates, and when they didn’t match had me confused.

Anyway, to progress this AlphaEss custom integration, I went back and carefully followed all the steps and found the problem:

  1. Make a custom_components/alphaess folder in your Home Assistant file system.
  • I created the directory under /config as custom_components/alphaess (so in full this is both /root/config/custom_components/aphaess and /config/custom_components/alphaess - since /config is linked as /root/config.
  1. Copy all of the files and folders from this repositary into that custom_components/alphaess folder
    • I cloned the git repository into this directory. So I thought I had all the files from the git repository in that directory, but actually they were in a subdirectory called homeassistant-AlphaEss (the repository name) which was created when I cloned the repository. Having moved all the files up one level so they sit in the alphaess directory… then continuing
  2. Restart Home Assistant (just the core)
  3. Setup this integration for your Alpha ESS energy storage system in Home Assistant via Configuration -> Integrations -> Add -> Alpha ESS
    – This now worked. The trick was to not just clone the git repository, but then move the files to the right folder.
  4. You will be prompted for the username and password for your account on the Alpha ESS website/app
  • Yes was as advertised.

So thanks for your help.

1 Like

The reason for that is that it is (theoretically) not something the Home Assistant user should ever have to concern themselves with. It is covered in the developer docs for developers who write UI configurable integrations.

Glad you got it working.

1 Like

Maybe also consider using HACS. It will save you a lot of trouble installing third party integrations. I don’t know this particular integration so I can’t say if it’s installable via HACS. This is just a general pointer.


I would very much like to see Alpha ESS integration into HA in a more pleasant way. Via HACS for example.