HA OS on unRaid!

Is this connecting locally or remotely that it takes that long?

Just local on my unraid box.

Are you running in a VM on unraid?

That’s not normal. If anything restarts are much faster unless you don’t have the resources allocated.
Or there’s something unique to your HA instance. Hard to tell without more info.

as docker containers. No VM.

Issue seems related about timing.

That’s a very buggy choice and not supported. This thread is about using a VM within Unraid.

Yes, as a VM in unraid.
Allocated 4 x Cores of an i7 processor, plenty of RAM and running off of Samsung SSD’s.

Never used to be like this, just changed over time.

Hi

I think i messed up. Have hassio running on ubuntu in docker on a nuc. Want to migrate to unriad and followed the guide.

When i set up the hassio before making the restore from snapshot I choose the same username as I have on Nuc hasso.

So when the snapshot restored I didn´t make full migrate. Everything don´t look the same. For exemple I have not HACS.

I have logged out and in after the snapshot.

Even tried to delete VM and make from scratch but same result. I quess the app data is the same, I don´t know how to fix this.

GOAL
Move from NUC Docker to Unraid
I possible keep same IP as I will not have to change all mqtt devices.

Regards

This is not an unraid issue. You should check your snapshot and make sure everything is in it. You also don’t need to create the same user. You can make a throwaway user and then when you restore the snapshot choose “wipe and restore”. Your old user will be restored and the temporary one should be gone. It’s also good to reboot the VM (supervisor > system page in the UI) after a restore.

Since upgrading to 0.108 that slow restart issue has disappeared.

Been running hassio as a vm for a while and been working great.

Today I added a pre flashed LSI card and Hassio VM will boot but gives me the Hass OS boot screen

  1. Autoboot
  2. Boot System 0
  3. Boot System 1
    4 SHell

Im stuck.

And alot of tried I get the guest has not initialized the screen problem.

Before I put in LSI card all was 100% prefect.

The card found the disk (thats not the problem)

My win10 win is running perfect, I´m on it now.

What to do?

Change back the unassigned disk to my mobo sata?

1 Like

My hass.io is running for a year now on my unraid. The slow boots is no issue anymore.

Only thing that still does not work is my USB Bluetooth LE adapter pass trough. I can pass my TI Zigbee controller and my ESP32s without any issue. Tried different Bluetooth dongles, never worked. Still bugs me.
Is it a unraid or a hassio problem?

I’ve been running Unraid and HA in a container for a year. I’m no Linux or HA expert. I just saw some comments above about high amounts of writes on SSDs and missing bluetooth dongles and I would like to share my experience.

@MagicMountainMan Unraid uses btrfs for its cache pool. I was running two NVMe in RAID1 and I too saw high amount of writes. At first I thought it was CoW enabled for docker.img, but no - system and domains shares have it off. However, it is enabled for appdata where HA db is located. I think the issue is btrfs pool specific. I have converted/balanced the pool to single mode. I do see less IO, but still higher because of CoW on appdata. I hope kernel 5.5 in Unraid 6.9 will fix that.

@dedi I’ve tried to pass bluetooth dongles to my docker container. Unfortunately, Unraid kernel have explicitly removed all bluetooth drivers/firmware. Even though the device is visible it cannot be started. I have read somewhere that the host OS should support the device in order to be available in the container. I have no idea if this is true also for qemu and VMs. It looks like it is a problem for you.

I have ordered five ESP32s to convert them to ESPHome bluetooth-MQTT hubs. and forget about native bluetooth support

I’m still thinking, if I need a VM with HassIO for the great plugin integration or should I stick to a simple container.

I hope my ramble helps some of you.

1 Like

Afaik there was bluetooth support added like a year ago or so in Unraid. Unfortunately that didn’t help.

I went also with ESP32s but still want Bluetooth on host for different things.

You’d have to confirm that your device has driver support from the HA OS. There are better ways to make use of bluetooth if using it for presence. Monitor.sh, Room Assistant are a a couple. Then you’d have the sensors reporting in to your “hub” instead of needing to be attached to it.

1 Like

Unaffected?

Yes, unaffected. If you are using the available HA OS images to run a VM in unRaid or anything else like Proxmox, EXSI, VirtualBox (meh), you are running the same environment that would be flashed to an SD and put in a pi. You’re just doing it with more power and resources available (presumably).

1 Like

Hey there, first off thanks for the awesome tutorial. I did this about 2 months ago and up to about a week ago it ran great. Suddenly it wont boot and I’m getting the following window suggesting the OS isn’t loading right with the Motherboard option I have selected?

Here are my settings for the VM in unraid:

Its all paired with Letsencrypt for my reverse proxy and a number of other VMs/Dockers on the unRaid Host

Additionally, when using Node Red inside the docker its always had connection issues. It says its not connected but everything appears to work just fine.

Any help would be appreciated.
Zach

Are you saying you changed an option afterwards? Motherboard?

Not really, I noticed the issue because I went to move the VDisk location onto the cache drive from the designated SSD I use and it wouldn’t boot. I moved it back to the designated SSD and maintained proper directories to it within the VM template and it still wouldn’t boot. I’m unsure if it was working just prior to that however. I do know it was working the night prior, but I forgot to verify it before I made the changes that morning. Judging by that popup I guess that the OS isn’t launching appropriately, the only time I’ve seen the VM like that is with OS issues or with Windows if I don’t have the right BIOS selected when making the VM. So honestly, I cannot fathom what would have made it act this way.