HA OS on unRaid!

did you make a copy of the vm prior to moving it?
if yes, just restore from there.
if not you maybe out of luck

Yes I did. I’m using the VM backup script plugin. I actually tried to restore from a three day old file when I KNOW that it worked and it still didn’t work after I started it back up. Tried pulling the VM Template settings in addition to the VDisk itself still to no avail.

Im getting like max a day before I need to shut down the VM and start again. Looked via VNC and saw this - what do this mean and what can I do?

New thought, is there anyway I can mount the qcow2 vdisk to windows and get the recover file off of it?

I am not aware of how you can do that. Do you mean converting it for hyper-v? Did you try creating a new vm instance which uses the current qcow2?

So I was able to re-create the VM from scratch using the existing disk, of course there’s some issues with Zigbee Devices I have been triggering manually, however for the most part everything is working well. It looks like the source of the problem was editing the VM template. I replicated the issue by changing names and directories again and it broke the VM. However, once again making a new template resolved the issue. I’m not sure why it would behave like that but I wanted to make sure that it was noted for anyone else who has troubles with it in the future. I will update this post if I notice any further issues down the line/as I reconnect to devices.
Cheers

Nice. I guess this is an unraid issue?

I once had two unraid servers going and when I knew some work was going to be done in the basement which required the power to be off for a while, I copied the HA qcow2 to the second server and attached it to a new VM instance, so that process came in handy to keep everything else running as expected.

I’ve also had a windows VM go bad after messing with pci-e passthrough and was able to fix it by re-creating a new instance as well. I ended up converting that back to a physical disk. No expert here, but unraid can be fun!

If I look here I see a beta of qcow2 install mehod. Is that a better choice then remaking a vmdk file?

Thinking if my problem is related to the hassos3.13 vmdk?

Seems like thr problem is within the VM (vmdk/qcow2 file)

I am currently using the beta 4.6 qcow2 file (for about 2 weeks) I haven’t had an issue so far. I allocated more space through the unraid UI instead of using the console.

We have some news I think

Hey All, how are you doing remote access into your hassio VMs? I used to do just the standard duckdns addon from within the VM but i’m toying with the idea of more SSL based access to other parts of my server (hoping to use multiple duckdns URLS).

I’d previously tried this as second reverse proxy on unraid but ran into errors with doubling up my certificates on the same external IP. A while back I found good instructions specifically for passing though to a hassio VM but now it eludes me.

Are we just following spaceinvader’s general video for reverse proxy?

Cheers

Linton

Maybe try that because now I get the cleaning needed all the time. Can´t get start up and get in.

just so I get this right.

If using the qcow2 file no need for any commands via command line?

Just place the file in a folder and manual setting and make the size like 30 GB via GUI?

If I pick manual then I can´t decide size in the gui it seems

Up and running, seems to be working. No crazy things in log so far

can someone point me to the benefits of running on a VM over a docker. I get that you don’t get the supervisor, but are the actual limitations on what you can do with Home Assistant?

No limitations. If you run the Home Assistant container from the Unraid App store (not the supervisor container…that’s a mess) you have a nice, fast instance of Home Assistant Core and you can use the rest of the UnRaid app store as your “addon store”.

2 Likes

Yes I say most dockers (addons) are in the unraid apps store already if your running unRAID you probably can add all the apps you need rather than using the supervisor.

Been running for a couple of days and its gets not acceable after some time, Sometimes it runs like 1 day sometimes like a couple of hours. Cant see anything strange in log.

Anyone else got this?

I mean with the beta qcow2.

Is it possible to resize the qcow2 image AFTER you’ve had an instance of HA running for months?

I dedicated 26GB originally, but need more space. Can I just run this to increase it by 10GB?

sudo qemu-img resize /mnt/user/domains/hassos_ova-3.3.qcow2 +10GB