HA password on iOS?

I installed HA on an RPI4, I can login to it directly (have a keyboard/mouse/monitor attached) with admin/admin. So far so good. Then, I installed Hass.io on my iPhone, it detects that Hass is running on my network, but then asks that I enter userID and password … and refuses anything I tried.

Yes, I did search for such info, but whatever I found does not do it …

So, what are the ‘default’ UserID and password on the iOS device?

You didn’t install hass.io on anything as it no longer exists. Are you saying you installed the HA companion app on your iphone? It will use the same username/password as HA on your computer.

You’re absolutely right. I did indeed install HA on an RPI4 … do you know what the default UserID and Password are ?

There is no default. You set that up when you do the onboarding first time you run in your browser. Whatever you used there you should use in the app as well

I’m not using any browser. I installed HA on a Raspberry PI, then I tried to access it from the iPhone App. Now, I did the same thing few weeks back and it worked fine. What I’m doing differently this time is, I installed the newest version of HA, and did a clean install as well of the iOS App. I do not recall ever having to go through web access. Has anything changed with the latest version ?

No. Try using a browser on your phone. It will require you to set a username and password on first connection

One more question: what’s the default http for the HA on the RPI ?

the IP address of the pi:8123

Thank you, I got exactly the same from checking the devices connected to my router. Now, when I run the iOS App, I get a ‘new’ error message:

Unknown error: The operation couldn’t be completed. ObjectMapper failed to serialize response

On the plus side, when I connect as you indicated (from Win10 computer), I get the screen below. I’ll take this as a good sign.

have you tried using a browser?

1 Like

Yes, by using a browser (from a Win10 machine), I get exactly the picture above. The error message I get that if I try to connect directly from the iOS App … I should let it do its thing for 20 mins ?

ah we cross posted… it is just installing HA and not ready to go yet. Yes a good sign. Takes maybe 20 mins to get to login screen

1 Like

Excellent. It worked exactly as you said. I was able to create userid/password in chrome, then login from my iphone. Thank you again, very much.

1 Like