HA RPi Migration - Pi 2B to Pi 4B - Success!

This is for reference to anyone attempting to migrate their RPi+SDCard to RPi+SSD. Im sharing my experience and what worked.

Existing Setup
RPi 2B
16GB SD Card (3rd Card in 6 years)
ZWave + Zigbee Combo USB stick (Nortek)
USB Bluetooth Adapter
Devices : 20 ZWave switches, 20 Zigbee Sensors, 2 Blueetooth sensors
Integrations : ecobee, Homekit

New Hardware :
Crucial P3 500GB NVMe M.2 SSD
SABRENT 4 Port USB 3.0 Hub Includes 5V/2.5A Power Adapter
SSK Aluminum M.2 NVME SATA SSD Enclosure Adapter, USB 3.2

Method : Restore from fill backup.

Attempt 1 : I followed the standard RPi4 + SSD instructions and brought the HA online. What didnt work?

  1. Zwave stick didnt recognize (had it directly on the Pi, so underpowered)
  2. Pi went offline few times

Attempt 2 : This time I bought the powered USB hub and followed the instructions from here. <<< This. Follow this word-to-word.

I had the Nortek on the USB hub and that connected to the USB 3.0 port
The SSD on the USB 2.0 port

Issues Encountered:

  1. HA CLI wont start! “Home Assistant CLI not starting jump into emergency console”
    Solution : Ensure the RPi is on Wired Ethernet!! I know! Its looking for something to update and wont use/configure the onboard WiFi. Power cycle after connecting the ethernet

  2. ZWave JS Failed Setup will Retry
    Solution : Disabled ZWave, Power Cycled and then Enabled ZWave JS and REBOOTed again and it just worked!! I didnt loose any device or automation

  3. Zigbee devices wont connect!
    Solution : Moved the USB 3.0 hub to the USB 2.0 Port. I know right!! What a bummer. And then Rebooted the HA. You do need to bring the Zigbee sensors close to the stick and re-pair it. Especially if you have Aqara door sensors.

  4. Add-Ons were greyed out.
    Solution : You wont believe it, the second power cycle fixed it.

Moral of the story : Go for a full shutdown - switch off power - wait 15 seconds - power on. I cant explain why but thats the thing resolved most of the issues!!

Im waiting on ORICO M.2 NVMe SSD Enclosure with which I will attempt to use the USB 3.0 port. This is one of the recommended

So successfully migrated to RPI + SSD and no more hung-ha due to SD Card.
Thanks to all community contributors that helped me in this process.

My HA is now rack mounted under my network switch.

1 Like

I have to ask. What’s the tiny brass horn for?

To toot my own horn!! :smiley:

1 Like