HA running but not healthy!

Hi folksl

I have installed HA now for my third time. The first time, I was doing great. I installed all kinds of apps. In that first installation, HA also said it was not healthy, but I guess it fixed itself because that msg went away. My problems started when I tried to install Duckdns. No matter what I did, I could not get back in. Never did. I decided instead to start over. This is where I am now. I started over and HA is working, but it gives that same error. System not healthy. I looked into it and it says HA is not privileged and that the system is not supported. That I should install HA under a supported OS like Debian. I’m looking into that presently.

Anyway, a couple of questions:

  1. Where does HA get the IPs that it gives to run the UI from? This time it gave That is not my IP. When I try to run HA from my IP, it does not run. I believe that was a part of the problem when I was debugging the problems with Duckdns.
  2. Should I just try to update HA with the OS I have running which is Ubuntu 20.04? I cannot do it from the UI, there’s no button or option for it like someone has said on this forum.
  3. Is the health problem going to fix itself or should I pursue that? Here is a screenshot of my system:

Screen Shot 2021-03-31 at 4.13.37 PM|690x353

Any advise would help me determine what i should do or path to take.


Ubuntu hasn’t been a supported OS for nearly a year now. Debian 10 is the only supported way to install HA Supervised.

No, you need to run Debian. Try this guide for Debian 10. I can’t offer help with DuckDNS as I do not use it.

I have download Debian from their website, but when I try to install it, it says it’s not for Arm-64 which I am using. I am installing it on a Mac with a M1 chip under Parallels. It is Parallels that says its the ISO is not for Arm-64. I left them a msg. Right now I don’t know who is right or wrong Parallels or Debian.

That is information you probably should have shared in your first post, as it’s a very new chip, and also an edge installation method.

You could try using the Raspberry Pi Debian image HERE as that is ARM based, but I’m not sure how much success you will have.

I would suggest using a dedicated machine, like a Pi or an old PC instead. If you wish to use you Mac with M1, you may need to run either HA Container or HA Core. More info on install methods can be found in an excellent guide HERE