HA-Sensor Shows 0 degrees in frontend of ESPHome "IR Remote Climate"-Card

Hi,

I have set up a working IR-transmitter using a ESP Wrover Kit, running Arduino Latest.
As shown in the Documentation I can import sensor data, from HA in my code to let it show ambient temperature in the climate card of this entity, but no matter what I do, it will only show 0 degrees - which is annoying.
In logs the sensor data I am interested in shows up as it should.

Here’s my code:

  pin: 33
  carrier_duty_percent: 50%

sensor:
  - platform: homeassistant
    id: temperatur_stue
    entity_id: sensor.atc_43f8_temperature
    unit_of_measurement: "°C"
    device_class: "temperature"
    state_class: "measurement"
    accuracy_decimals: 1

climate:
  - platform: mitsubishi
    name: "Varmepumpe"
    set_fan_mode: "quiet_4levels"
    supports_dry: "true"
    supports_fan_only: "true"
    horizontal_default: "left"
    vertical_default: "down"
    sensor: temperatur_stue

Any Ideas?

My Log looks like this:

INFO ESPHome 2024.3.2
INFO Reading configuration /config/esphome/stue-media.yaml...
INFO Starting log output from 192.168.0.137 using esphome API
INFO Successfully connected to stue-media @ 192.168.0.137 in 0.107s
INFO Successful handshake with stue-media @ 192.168.0.137 in 0.087s
[16:48:50][I][app:102]: ESPHome version 2024.3.2 compiled on Apr  8 2024, 16:43:27
[16:48:50][C][wifi:580]: WiFi:
[16:48:50][C][wifi:408]:   Local MAC: B0:B2:1C:51:EF:C8
[16:48:50][C][wifi:413]:   SSID: [redacted]
[16:48:50][C][wifi:416]:   IP Address: 192.168.0.137
[16:48:50][C][wifi:420]:   BSSID: [redacted]
[16:48:50][C][wifi:421]:   Hostname: 'stue-media'
[16:48:50][C][wifi:423]:   Signal strength: -39 dB ▂▄▆█
[16:48:50][C][wifi:427]:   Channel: 6
[16:48:50][C][wifi:428]:   Subnet: 255.255.255.0
[16:48:50][C][wifi:429]:   Gateway: 192.168.0.1
[16:48:50][C][wifi:430]:   DNS1: 192.168.0.1
[16:48:50][C][wifi:431]:   DNS2: 192.168.0.1
[16:48:50][C][logger:166]: Logger:
[16:48:50][C][logger:167]:   Level: DEBUG
[16:48:50][C][logger:169]:   Log Baud Rate: 115200
[16:48:50][C][logger:170]:   Hardware UART: UART0
[16:48:50][C][psram:020]: PSRAM:
[16:48:50][C][psram:021]:   Available: YES
[16:48:50][C][psram:024]:   Size: 4095 KB
[16:48:50][C][restart.button:017]: Restart Button 'Restart'
[16:48:50][C][remote_transmitter:015]: Remote Transmitter...
[16:48:50][C][remote_transmitter:016]:   Channel: 0
[16:48:50][C][remote_transmitter:017]:   RMT memory blocks: 1
[16:48:50][C][remote_transmitter:018]:   Clock divider: 80
[16:48:50][C][remote_transmitter:019]:   Pin: GPIO33
[16:48:50][C][remote_transmitter:022]:     Carrier Duty: 50%
[16:48:50][C][climate_ir:076]: IR Climate 'Varmepumpe'
[16:48:50][C][climate_ir:077]:   Min. Temperature: 16.0°C
[16:48:50][C][climate_ir:078]:   Max. Temperature: 31.0°C
[16:48:50][C][climate_ir:079]:   Supports HEAT: YES
[16:48:50][C][climate_ir:080]:   Supports COOL: YES
[16:48:50][C][mdns:115]: mDNS:
[16:48:50][C][mdns:116]:   Hostname: stue-media
[16:48:50][C][ota:096]: Over-The-Air Updates:
[16:48:50][C][ota:097]:   Address: stue-media.local:3232
[16:48:50][C][ota:100]:   Using Password.
[16:48:50][C][ota:103]:   OTA version: 2.
[16:48:50][C][api:139]: API Server:
[16:48:50][C][api:140]:   Address: stue-media.local:6053
[16:48:50][C][api:142]:   Using noise encryption: YES
[16:48:50][C][homeassistant.sensor:030]: Homeassistant Sensor 'temperatur_stue'
[16:48:50][C][homeassistant.sensor:030]:   Device Class: 'temperature'
[16:48:50][C][homeassistant.sensor:030]:   State Class: 'measurement'
[16:48:50][C][homeassistant.sensor:030]:   Unit of Measurement: '°C'
[16:48:50][C][homeassistant.sensor:030]:   Accuracy Decimals: 1
[16:48:50][C][homeassistant.sensor:031]:   Entity ID: 'sensor.atc_43f8_temperature'
[16:48:50][C][audio:203]: Audio:
[16:48:50][C][audio:225]:   External DAC channels: 1
[16:48:50][C][audio:226]:   I2S DOUT Pin: 14
[16:48:52][D][homeassistant.sensor:024]: 'sensor.atc_43f8_temperature': Got state 23.58
[16:48:52][D][sensor:094]: 'temperatur_stue': Sending state 23.58000 °C with 1 decimals of accuracy
[16:48:52][D][climate:396]: 'Varmepumpe' - Sending state:
[16:48:52][D][climate:399]:   Mode: HEAT
[16:48:52][D][climate:404]:   Fan Mode: AUTO
[16:48:52][D][climate:410]:   Preset: NONE
[16:48:52][D][climate:416]:   Swing Mode: OFF
[16:48:52][D][climate:425]:   Target Temperature: 23.00°C

My Climate Card:
Heatpump

could you please check in ha template tool that this returns a numeric value

{{states("sensor.atc_43f8_temperature")}}

Look for “result type”

I’m guessing here but try adding internal: false to your config.

Maybe it’s not getting re-exported somehow due to the default behaviour of imported ha sensors.

It returns a plain:
23.06

Earlier I tried without specifying anything about sensore type etc. YAML, nothing worked.

I will try compiling and test now.
Didn’t work, but it is still reporting correct value in Log

1 Like

Look for the words “result type”