HA stops work every Monday

Good Morning,
since mid / end of December i have noticed that my HA installation always stops working on Monday mornings.
In my office, the blinds are raised every morning at 7:55 a.m. That still works. at some point later HA no longer reacts.
I can no longer access the WEBUi, SSH or the APP. PING still works!
At first I suspected the IP lease and therefore switched from dynamic IP to static. But that was unsuccessful.
The system is installed on a Raspi4 with HASSIO.
In the LOGs (supervisor, core etc.) I can’t find anything that would help me.
Does somebody has any idea?

2 Likes

Look at the automations you have that run only on Mondays.

I already thought about that. But I don’t have any automation that only runs on Mondays.
Could the LOG file be the trigger? What if the LOG file always reaches a certain size on Mondays and the system therefore stops?

Unlikely considering I just watched a home assistant conference talk where the user had a 60GB log file (he was monitoring a factory).

madness, that’s big.
In fact, I don’t think size is the trigger. My SD card is only 8GB in size (I think).
The system may simply run full. The thought occurred to me earlier.
If I delete the log file on Wednesday, the time should shift.

The fact that it happens reliably at the same time every week suggests it is not a resource issue (which will be highly variable) and is something scheduled.

1 Like

It won’t be easy without a LOG. I’ve been thinking about what I’ve built in in mid-December all the time. I think the last one was the Alexa integration.
Here I can trigger an automation via an Alexa command, which then sends me an announcement. We do this almost every morning.
As I said, I don’t have any automation that only runs on Monday morning.

The fact that you can’t SSH in makes it difficult.

I would do this:

  1. On Monday morning, before the system goes down, increase the logging level to debug.

  2. Wait for it to go down.

  3. Put the SD card in a Linux PC or use Linux Reader (free) on a Windows PC and check the config/ home-assistant.log file contents.

1 Like

that’s a good approach. I will do it. Thanks for the suggestion

Are you sure it’s failing on Monday or is it you only notice it after Monday?

You testing daily?

Which SSH service are you using? The one provided by an Add-On or the native one that works via port 22222?

If you can ping it then it implies the operating system is functional (and can be accessed via the native ssh) but docker has crashed and rendered all its containers non-functional (Home Assistant, Supervisor, and all Add-Ons including the Web Terminal/ssh Add-on).

I can actually see that it could be seen as crossing a line if you have had some lost in such an event.

I did not know it was visible to others.
What was the point in “deleting” the post of it’s still visible?

I am very sure that it only happens on Mondays. The first time I only noticed it after my lights didn’t come on in the evening. Today he didn’t send my garbage disposal mail. This automation runs daily at 9:30 a.m. At this point it had already crashed Everything works fine on the rest of the days.

Tomorrow I have to check which port I have set Putty to.

If you don’t remember performing all the instructions to activate port 22222 (in the link I posted above) then it’s unlikely you are using that port (and likely to be using port 22 via an ssh Add-On).

I had a problem with docker health-check scripts hanging up. I disabled the checks and it now works. I’ve never found an explanation.

Which version and was it Home Assistant OS (formerly known as hassio)?

good morning,
it really is the case that I only use port 22.
I thought I changed that to 22222.
Then maybe I should do it.

Nothing to do with home assistant; this is with mode-s monitoring. I never got to the bottom of it but it seemed to be a docker problem. The check script would return the right value but it wouldn’t terminate and that caused the container to hang.

I just threw it in in case the OP’s container had a health check script that ran weekly on Monday. Or something like that.
Long shot!