HA suddenly crashes every 1 or 2 days

Hi there, I’m a HA user from a while now and since about 1 year I’m running it in a Proxmox VM on a NUC.

Here you can find my specs:

And my VM setup:
Schermata 2021-04-19 alle 11.25.55

Since 3-4 months I’m experiencing random crashes every 1 or 2 days of operation of the VM. Web interface becomes unavailable or unresponsive as well as the CLI through Proxmox UI.
The following are some screenshots taken after the crashes:

(Note the CLI was responsive but the banner didn’t show up and the command didn’t work)

(This time the CLI didn’t respond to any input)

And one after a reboot:

Some other facts:

  • I download the HassOS image, create the VM and import the image all manually because Whiskerz script had not always worked as intended;
  • I did it several times;
  • I recently formatted the SSD and reinstalled Proxmox and all the VMs from scratch. This solved only the MariaDB corruptions (?). :tired_face:

Please help me debugging this mess, I don’t know what else I can do.
Thank you in advance to the brave persons who would support me. :slightly_smiling_face:

I don’t know if this is related, but I’m also experiencing a persistent error loading Automations while the Check config tool, both from web UI and CLI, doesn’t highlight any problem nor the logs show any related message (please see the last screenshot). Also, the Core Configurator check is OK.

I see error related to rtsp.
What camera integrations you using?

Also what custom components you using?

Hi tmjpugh,

I’m using Generic. Onvif works good too, but I’m on Generic right now.

My Custom Components:

Please note that those related to Samsung TV are present but not active, in fact the entries in the Config file are commented out.

Here we are again:

After an attempt to log in: