HA supervised on a 32 bit laptop?

Is there (still) a way to have a 32 bit laptop running HA?
I used to have one one year ago.

I know Docker is not a problem, you can install it in a 32 bit OS with:

sudo apt install -y docker.io

My idea is to have a 32 bit laptop running Debian 10 and HA supervised. But every time I try… actually I can install Home Assistant, but I can’t restore any image, neither update, so it’s kinda useless.
It also says it has an unsupported and unhealthy system.

Any ideas?

how are you trying to install supervised?

Using this:

But installing docker 32 bits instead

i believe that script pulls a 64bit image of ha, you need it to pull qemux86 image not qemux86-64

you need to append the machine type to the command to run the script.
see here: https://github.com/Kanga-Who/supervised-installer/blob/master/README.md#supported-machine-types

This is one of the issues I first ran into a few years ago using a 32bit machine. I found (at least for Intel/AMD) that most Docker images are “built” for 64 bits. You may find some that are 32 bits, but I suspect you’ll eventually come across an image that does not support 32 bits.

I’ve tried with -m quemux86, but it didn’t work :frowning:

I guess the problem is the Docker version: 18.09 for 32 bit machines… That marks HA supervised as unhealthy so I can’t update or restore

I’m still looking for a way to have HA supervised on a 32 bit laptop… Any ideas?

Someone found a solution? i have also a 32bit laptop ready for HA!

here is solution https://github.com/ntguest/32bit-home-assistant-supervised-installer

you say old 32 bit nettop supported but there’s no generic-x86 machine type in the list?

using my way you dont need to select machine type for 32bit pc’s. see video https://youtu.be/DqlCx-hnWkE

Necroposting on three threads that get thrown up in Google about this

I’ve been able to get the latest version of HA supervised running on a Sony Vaio P (who remembers those), which is shaping up to be a great little low power HA server which is small, has built in WiFi, built in screen ect for admin and looks great sitting in my entertainment unit. I am sure any of the other late 00’s and 10’s cheap netbooks people have lying around would be just as good.

What I had to do was recompile the supervised installer to accept docker.io as a dependency.


  1. Setup the system with Debian 12, ticking yes to linking the backported software repositories

  2. Follow the instructions for installing HA here: https://community.home-assistant.io/t/installing-home-assistant-supervised-using-debian-12/200253?u=homearesistant
    a) Dont run the line curl -fsSL get.docker.com | sh, which installs docker-ce, instead install docker.io which is included in the standard debian repositories for i386: sudo apt-get install docker.io
    b) Use the 32 bit version of os agent: os-agent_1.6.0_linux_i386.deb
    c) Grab the source code for the home assistant supervised installer and modify it to support docker.io https://github.com/home-assistant/supervised-installer/tree/main
    i) Change the line in /homeassistant-supervised/DEBIAN/control from Depends: curl, bash, docker-ce, dbus, network-manager, apparmor, jq, systemd, ... to Depends: curl, bash, docker-ce | docker.io, dbus, network-manager, apparmor, jq, systemd, ...
    ii) Compile to .deb (using the command found in .vscode/tasks.json) chmod 555 homeassistant-supervised/DEBIAN/p* && dpkg-deb --build --root-owner-group homeassistant-supervised
    d) Use the new homeassistant-supervised.deb you just created instead of the released .deb

This got me a fully functional x86 install of HA supervised that is happily supporting my MQTT devices and runing the website with good speed. Theres a chance some docker containers won’t work, but this has not been a concern for me.

Lets keep these little power efficient x86 pcs out of e-waste :slight_smile:


1 Like

Although I am quite new to Linux/Debian the above worked for me, except to install the newly created .deb
Somehow installing using “sudo su - “ or “sudo -i” gave errors.
For me this worked: “Sudo apt-get install ./homeassistant-supervised.deb”
(Don’t ask me why)

Thanks @homearesistant for the steps above!