HA Supervisor doesn't see my Add-on running

I ran into a problem with the Supervisor and the Add-on “Studio Code Server”.

If I try to start the addon, the logs state, that the Add-on is running:

Add-on Log
s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting
 Add-on: Studio Code Server
 Fully featured Visual Studio Code (VSCode) experience integrated in the Home Assistant frontend.
 Add-on version: 5.8.1
 You are running the latest version of this add-on.
 System: Home Assistant OS 10.3  (aarch64 / raspberrypi4-64)
 Home Assistant Core: 2023.7.2
 Home Assistant Supervisor: 2023.07.1
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-timezone: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
[11:57:30] INFO: Configuring timezone (Europe/Berlin)...
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service base-addon-timezone successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-user: starting
s6-rc: info: service init-mysql: starting
s6-rc: info: service init-mosquitto: starting
s6-rc: info: service init-code-server: starting
s6-rc: info: service init-code-server successfully started
s6-rc: info: service init-mysql successfully started
s6-rc: info: service init-mosquitto successfully started
s6-rc: info: service init-user successfully started
s6-rc: info: service code-server: starting
s6-rc: info: service code-server successfully started
s6-rc: info: service legacy-services: starting
[11:57:33] INFO: Starting code-server...
s6-rc: info: service legacy-services successfully started
[2023-07-19T09:57:35.225Z] info  Wrote default config file to ~/.config/code-server/config.yaml
[2023-07-19T09:57:36.777Z] info  code-server 4.14.1 5c199629305a0b935b4388b7db549f77eae82b5a
[2023-07-19T09:57:36.783Z] info  Using user-data-dir /data/vscode
[2023-07-19T09:57:36.861Z] info  Using config file ~/.config/code-server/config.yaml
[2023-07-19T09:57:36.861Z] info  HTTP server listening on
[2023-07-19T09:57:36.861Z] info    - Authentication is disabled
[2023-07-19T09:57:36.861Z] info    - Not serving HTTPS
[2023-07-19T09:57:36.862Z] info  Session server listening on /data/vscode/code-server-ipc.sock

but I am not able to access the frontend, not via the sidebar nor via the Add-on page, both state, that I have to start the Add-on:

I tried to find help on the according github page https://github.com/hassio-addons/addon-vscode/issues/679

but since the add-on is running, there is nothing wrong with the add-on and this seems to be a Supervisor-problem:

only thing related in the supervisor log
23-07-19 12:34:55 WARNING (MainThread) [supervisor.addons.addon] a0d7b954_vscode is already running!
23-07-19 12:36:55 WARNING (MainThread) [supervisor.addons.addon] Timeout while waiting for addon Studio Code Server to start, took more then 120 seconds

Is there a way to update, re-install or force the Supervisor to access the Add-on? Anything else, I could try?

Thanks in advance!

Have you restarted/rebooted HA ? (or just supervisor, essential to know !)

I had this issue, container started but supervisor did miss it (or container missed to inform it properly).

Restarting the machine helped me because i could not stop the container from supervisor and I was too lazy to run a command to stop the container manually (command line)

I tried to reboot HA on multiple occasions. I tried to uninstall, reinstall, turn off (and on) watchdog, not to have it start from boot and restarted every single time in between.

But it didn’t help. I’ll try a restart next, but could you go a little more into how to stop things from command line?

Update: I restarted the PI (not just a reboot but I took it off the power) and after it was back, there was an update for the add-on. I installed it as well and Studio Code Server started afterwards. Thanks for the help!

sudo docker stop add-on-slug
1 Like