HA takes my router down?

Just so you know, you don’t have to hide any 192.168, 172.16, or 10. addresses because they are non routeable addresses.

This seems more likely to be related to network settings on the device running HA. Can you provide some details about the device and operating system?

In particular, make sure the device is not running as a DHCP server.

That looks like the “your connection is not private” page that you get when you try to access a https site over http.

I think if you hit the “Advanced” link it will allow you to get past that screen and then just takes you to the HA page.

You will see that every time you visit that page but it is able to be done.

There are ways to avoid it but it takes some additional configuration.

No. It’s when you access a https site with anything other than the hostname that the certificate was registered with.

1 Like

yeah, thanks for the correction. :slightly_smiling_face:

Its running on a Synology NAS inside a docker container. My device isn’t a DHCP server.

How can I do this additional configuration?

How about a DNS server (eg: PiHole)?
Do you have the same problem when accessing HA from a different client device?

No, also no dns server.
I have it on all devices in my network.

Just saw your message.
I have had exactly same problem a few weeks ago.
Also SSL errors… Router stopped responding and rebooted. It started after an home assistent update to a newer version. Finally reinstalled homeassistant and problems went away.
One of the strangest thinks that happend to debug in a long time i think.
First i thought it was a dd wrt firmware bug on my r7000 router but when i reinstalled fresh home assistant after a while everything was workibg normal. But still weeeiird issue

Ohh also problem went away if i rebooted home assistant/rpi and router. Then when everything was ok again… as soon as i opened home assistant in my browser, problems started again

you have two (common) options:

NGINX reverse proxy or VPN

I personally use a VPN and it makes things way easier and arguably way more secure than duckdns/letsencrypt.

You have a couple of different options for setting up a VPN.

My router supports it’s own OpenVPN server so I just set that up.

But before I realized that my router had that functionality built-in I had previously set up PiVPN on an extra Pi I had laying around.

Using a VPN allows me to connect directly to my HA instance usinbg the IP address while I’m connected to my home network (wifi or LAN) and then if I need to access HA while I’m not on my home wifi network I literally just click a button to connect to my VPN and I can access my HA (or anything else on my network) just as if I was connected to my router through wifi sitting in my livingroom.

The connection is securely made by setting up server/client key files that someone would need to have on their device to allow access to the VPN. And communication is encrypted so no one can listen in on your traffic.

I can give you a quick and dirty procedure that you can use to install it on a Pi and may be able to be adapted to use on another device. But it’s even easier if your router offers the built-in functionality.

I also have a NGINX proxy set up in my Docker but I really don’t use it for anything. It was more of a “let’s get this running in case I need it at some point down the road”. So it just sits there running along doing nothing except for the occasional test to make sure it is still working.

Did a full reinstall this weekend, no success. After using HA for 2 minutes, the router went down…

I’m looking into nginx. I will try to set this up.

This could be related to the UPNP sensor in HA? Try disabling it?

I’m not using this sensor. So I’m affraid this isn’t the reason its failing…

I don’t think it’s related to the issue, but I’m running HassIO on my Synology NAS using a package from this thread: Hass.io on Synology DSM (native package)

Doesn’t look like you’re the only one who is having issue, saw another 3 similar posts popped up. The recommendation was PiHole and dnsmasq.

Just curious, what if you use Google nameservers, instead of your ISP DNS? You could plug in Google nameservers on your router. The reason I’ms saying this because I host my own mail server. When I’m at home, it understands FQDN. Once I switched to ISP’s nameservers, it doesn’t. It might work in your case.

Also, I don’t speak your language, but if I understand correctly that ssl error/warning is normal. It’s telling you that the issued certificate could not be verified. Since you know it is your server and not being directed to another server, it’s harmless.

I can try using the Google DNS on my device this evening. I can’t change this in my router because almost everything is blocked by my ISP.

I know the SSL error is normal, I’m just trying to give as much information as possible :slight_smile:

I am using hassio on a raspberry pi and I also use a Telenet wireless router. I don’t have any problems.
Did you try to disable upnp on your Telenet router ? You can find the setting in the advanced settings of your router.