HA test in Virtual Box not booting

Hey everyone,
I just startet with a virtual box on my MacBook Pro to test HA if it is the right thing for me and my LCN Smart Home.
everything went well so I decided to by a Leno Think Centre M710q.
Vbox was not running 24/7 while testing.
I already created the backup file but forgot to transfer it to my pc.
Now I didn’t get it running. I am checking an test it for several days now but nothing I found helped me.
Is it possible to extract it out of the VM files? or maybe just the config.yaml / secure.yaml.

When I start my HA in Vbox there always comes an Message:
I already tried:
supervisor repair / supervisor restart
and a lot other stuff. didn’t get it running.
The new HA on proxmox is ready to get startet but my LCN Smart home has no direct implementation so I added every light / switch / shutter and so on by hand in the config.yaml. it took me ours and ours to do it.

VBox + HA seems to have a lot of problems, there are dozens of threads about issues using the two together. Proxmox is a better solution for linux virtualization but isn’t quite as easy to use. For me, on my Mac, I use VMWare Fusion to run HA and it’s rock solid - and it’s also free.

You could try another VM with e.g. Debian, and then attach the HA OS .vdi to that VM. That way you could extract the backup/yaml files.

Yes that’s why it was just a test in the virtual box, but that does not answer my question?!

thats a good idea, tried to do it with Parallels desktop for mac os but i get the message:

  • Virtual disk conversion failed.
    The guest operating system installed on the hard drive cannot be recognized. You can still convert this disk by using the prl_convert utility with the --allow-no-os option.*
    but I can’t find this prl_convert utility in my tools or to download online. Any idea?