HA Unable to find Hue scene

For a dedicated set of lights, I created a scene Off today in the Hue Clip api debugger, as I’ve done many times for other lights.

Normally, that scene is available immediately for use in the HA hue.hue_activate_scene service. I’ve done so successfully last week…

These new scenes today however return a ‘unable to find scene’ error in the HA Log.

They are available and live, and correct, in the Hue api, where I can see them nicely with all my other created scenes.

I know my way of calling the scene is correct, because I can call other scenes, with the same namem and the lights turn_off nicely.

Would any of you Hue’ers have an idea where to start debugging this? Ive restarted the Hub, both my HA instances, and the error remains the same.

Ive also deleted these scenes and recreated them. No such luck…

Hope you can have a look

Have you tried calling it something different? You have to be careful about calling things key words.

In this case, there are no default scenes ‘Off’ on the Hue hub/api, and I’ve discussed that on the developers forum. If have several others, in fact for all my groups…
So that shouldn’t be it. I feared I may have reached the max scenes allowed, but if that were the case, I think I should see another error.

But, for the sake of it, Ill create an extra scene ‘Uit’… and see what happens.

Nope. Same result. If I turn on the scene, either in the frontend or the dev-service, I can see the lights respond to ‘something’ in the App, but they stay on.

‘shouldn’t be it’ but might be, because Homeassistant might be sending ‘off’ in a different way because its a key word.

Other than that, I got nothing on a first glance.

yes, I hear you. But I have done so before, and these older scenes for lights still work, and they are created identically, and also called ‘Off’, as is displayed in the API Cli … really really strange this is.

small update, think I found the issue, though it is a bit difficult to explain.

It dawned on me I had recently added a zone, a new feature in Hue App, to my lights groups. This zone consisted of 2 existing other groups. 1 of these groups wasnt answering anymore to the hue scene commands, no matter what. That’s to say, the hand made scene, the builtin scenes were fine.

Today I cleared my Hue install, and had to rebuild all scenes manually… pfff.
Also, deleted all manually created scenes, and rebuilt them again, which went alright . Until I arrived at that 1 group again…

I then decided to delete the zone, and the group started listening again! I also was able to use the others, and all seems to be working as expected.

(had a whole other issue re-adding Hue to the Google Home again, took me about 20 times, with several restarts and reboots, but even that is working gain :wink: )

all in all this has been an experience I don’t like to repeat, so I am a it weary to add zones again, though that is a magnificent feature.

Also, I must fear this has to do with the Homeassistant support for Zones, because it was all perfectly created on the Hue system, and Api checked 100% correct.
Don’t know who to tag in the dev’s for the Zone support, never got a response on an issue I filed for that some time ago.

1 Like