HA Yellow, Z-PI7 and Bluetooth


Are there instructions in which to get an Aeotec Z-PI7 working on a Home Assistant Yellow?

This says that it’s supported, and Paulus himself says it’s working on the Yellow. However, I cannot find specific instructions to get it working anywhere, and a lot of forum threads end with no resolution.

The Aeotec instructions say to disable Bluetooth as it uses the same UART channel as what is brought out to the headers. But how can I do that if I have a Yellow with everything on NVME? There’s no SD card to pull out to modify config.txt, and the SSH addon in HA only lets you snoop around inside the container, not the OS.

This is the log output from the Z-Wave JS addon:

Error in driver ZWaveError: Failed to initialize the driver: ZWaveError: Timeout while waiting for an ACK from the controller (ZW0200)

There are options for the following devices on my Yellow: ttyAMA0, ttyS0, ttyAMA1, and ttyAMA2. All of them give the same output.

Please advise.

hmmm. Upon following the developer instructions to ssh into the host OS on the Yellow, I noticed that the config has miniuart-bt configured by default.

Additionally, I tried to test the Z-PI7 on a normal Raspberry Pi 4 I have, and the Pi won’t even boot up with it inserted. Both the yellow and green LEDs remain on (again, the Pi, not the Yellow).

Maybe I just have junk hardware.

Got this, it worked.

The Z-PI7 must be bad.

My understanding is the Z-PI7 shows up as TTYAMA1, so if this failed, maybe you did have a bad one.
I also use the ZWave ME RazBerry 7 so can;t give any personal exerience with the AEOTEC product.

It was /dev/ttyAMA0 for me on the Yellow

I also seem to have had this problem with the AEOTEC, which is surprising, since I have used a bunch of their zwave products with success, but even plugging in an older razberry worked from the start, so it seems that the Z-PI7 has some issues, either in manufacturing or firmware. I have not tried the device on a normal PI and I had it too long to return it (ordered a while ago but couldn’t get a CM4 till recently) I am going to try the new RazBerry linked above (going to order it now, fingers crossed)

I was originally looking at the Z-Pi 7 as well, but I couldn’t get it for my region (according to Aeotec), so I went with the Razberry 7 as I stated, as this was compatible with all regions (firmware selectable).
I found it showed on Device /dev/ttyAMA0 and it just worked. Z-Wave is one thing I have never had an issue with on my system.
The Razberry 7 is small, like the Aeotec version, and fits really nicely inside the HA Yellow case. Don’t get the older Razberry 2 devices based on 500 or earlier chipsets as these are larger and don’t fit nicely in the HA Yellow case

Just to follow up, I got the razzberry and it worked out of the gate, so yes, I think there is a defect in the ZPI7, either firmware or hardware, possibly a mfg run issue, as I got mine almost a year ago, but could not use it until recently (needed the CM4)

1 Like

Good to hear it worked out :).
I had a long delay waiting for my CM4 also. Luckily I had a spare Pi 3 and I was able to test the Razberry 7 I got, and update it’s firmware, using zwave before I installed it on the Yellow :slight_smile: