HA + ZHA + Conbee 2 at Synology

Hi
In the beginning, I will add that I searched the forum, watched a thousand videos on youtube and still can’t cope with installing Conbee 2 on Synology in HA docker. :confused: So any help will be much appreciated.

I have:

  • Synology 220+
  • docker with homeassistant
  • Conbee II

When I try to add integration: ZigBee home automation on HA, I choose radio type deCONZ and type serial device path: /dev/ttyACM0 . However, then I receive Failed to connect. (I do not have /dev/serial/by-id/usb-dresden_ etc path visible on synology)

When I added a separate docker deconz, it works without any problems, and Conbee II is detectable and I can log in to the device.

Any suggestions? I will accept any help! Thanks! :slight_smile:

Cheers
Szaq

ok. Solved :smiley: synology and that helped… now it works. Maybe this will be useful for other community members.

Cheers!

You should consider to use HA as a virtual machine instead of a container. You have more possibilities in HA.

1 Like

This is identical to my configuration. @Szakalito have you been able to run 2021.05.x with this?

I tried upgrading from 2021.04.0 → 2021.05.5 and Zigbee stopped working. No serial device found. Back to .04 and it’s fine. Can you confirm?

+1 You should run HA OS in a VM instead if you have an x86-64 (Intel or AMD) based Synology.

Hi @Szakalito, I’m having the same problem.
I have a PI3 running with the USB stick and there’s no problem with the Zigbee Home Automation integration, but when I tried to move everything to my QNAP using containers I had the same issue, deCONZ is discovered, but adding devices there is a pain in the a$$. If I use the ZHA integration, I cannot add the ‘Serial Device Path’, I tried /dev/ttyACM0, the mounted path ( /root/.local/share/dresden-elektronik/deCONZ) but nothing works. I have the container running in privilege mode too but no luck.
By the way, I’ve followed this web
Any other option? Also, what are the benefits of using a VM and install HA instead of a HA container?
Thank you

Hi, right now, I have Home Assistant 2021.5.1, and it works. I updated it from 2021.04.0. I’ve just followed the instructions on the web.

Hi
From what I noticed with docker containers everything is about adding rights to the container or using admin. I was fighting a long time but at the end adding admin rights helped with my problems and now works like a charm.

OK. Weird. No matter what I try, added permissions, etc, I cannot seem to upgrade past 2021.04 and have my deConz conbee II detected in the container. Even tried rebooting the NAS. It’s happy on .04 tho :frowning:

Welp, I managed to upgrade to 2021.08 - where the previous working one was 2021.04. I had to manually edit my config file .storage/core.config_entries and changed the old

                "data": {
                    "radio_type": "deconz",
                    "device": {
                        "path": "/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2415090-if00"
                    }
                },

to

                "data": {
                    "radio_type": "deconz",
                    "device": {
                        "path": "/dev/ttyACM0"
                    }
                },

And it seems to work OK now. I suspect someone thought it a good idea to remove serial drivers from the Docker image.