HA, ZHA, Conbee II, and IKEA Tradfri Shortcut Button


  • HA running in VirtualBox VM on Ubuntu with a Conbee II Zigbee radio
  • Dongle is connected via an extension cable for reduced interference
  • Already successfully integrated Hue devices (bulbs, plug, and dimmers) both using the Hue bridge, as well as directly via ZHA.
  • Already successfully integrated 1 IKEA Tradfri bulb via ZHA.

Fairly new to Home Assistant, but have had reasonable success to date, once I got my head around some of the potential interference issues with the Conbee II stick.

Just picked up a bunch of IKEA Tradfri devices and started setting them up in ZHA. First was a bulb (just plain warm white), which worked perfectly, and which I’m controlling via a Hue dimmer and my own custom automation for the buttons.

Unfortunately, I’m having problems getting the Tradfri Shortcut Button to work properly. I was able, after several tries, to get it added to ZHA, but it only shows up with the battery sensor, and the Identify button service (in diagnostic section of the device listing). No other sensors or info shows up.

I have tried, after reading several posts here, to listen for the zha_event event, and the button is not producing any events of that type (the Hue Dimmer buttons do, however).

I also tried flashing the Conbee II to the latest firmware, which is what allowed me to get the buttons to complete the initialization process (prior to updating the Conbee II the device would get stuck on the “Initializing” step during the pairing process).

My next thought is to update the FW on the buttons, but I don’t have an IKEA hub, so I’m not sure whether I can do that with the devices in their current state (I saw a post that outlined how to check the current firmware version on the buttons, but that isn’t working for me, possibly because I can’t get the button click to work to send that info).

Any suggestions on where to go from here would be welcome!


In my experience, all IKEA devices are a little picky and kind of “drama queens”. :slight_smile: Unfortunately, because they are cheap and if you get them to work, they work reliably. :slight_smile:

What helped me a lot, was changing from ZHA to Zigbee2MQTT. I’m not sure how you’re running HA, if it is with HA-OS or supervised as installation method, you can use the Zigbee2MQTT-AddOn from the store.

ZHA is based on Z2M (Zigbee2MQTT), meaning new devices and fixes are mostly added first in Z2M, and then copied to ZHA in a later release. But the main things still happen in Z2M, as this is the go-to standard in Zigbee. :slight_smile:

I found another thread that may help you move along, take a look here:

If you ask me, I’d change to Z2M and try again. :slight_smile: Sorry, can’t be of more help here, the IKEA devices are the only ones, that mess around in my otherwise flawlessly working HA setup… :slight_smile: So you’re not alone. :smiley:

Huh? That’s just not true.

Z2M often gets support for odd devices earlier than ZHA, but only because of its more established and larger user base. To my knowledge ALL devices in Z2M need a converter manually written for them.

ZHA is a very different beast under the covers with a different code base. ZHA was designed to be standards based. As such, many new devices are supported natively with no additional coding necessary.

The newly released Sonoff S40 plug I bought last week is a good example. The thing was useless in Z2M until I installed a custom converter. A months old ZHA install supported it automatcally because the device follows zigbee standards.

Unfortunately, too many devices do not follow zigbee standards, negating much of ZHA’s advantages.

At the end of the day, I prefer the design goals of ZHA, but use Z2M. Z2M often presents more device options in an easier to use format than ZHA, probably because every device is added manually.

1 Like

I may give Z2M a try, given that I still have relatively few devices on ZHA at the moment.

Do I need to remove ZHA entirely, or is it enough to just disable it?

Would like to minimize the disruption if I decide to go back to ZHA.

Had already found that thread, and unfortunately, it’s not quite the symptoms I’m seeing. I was seeing similar symptoms before updating my Conbee II dongle, but now it looks like the button pairs normally, it just doesn’t provide any events.

I probably should not be surprised, but apparently what I needed to do was wait.

After being away all day, the shortcut button is now firing zha_event events when pressed, and works with the debounced shortcut button blueprint.

Need to check if the manager clusters piece is working, and see if I am able to update the button firmware OTA, but if so, I will probably stick with ZHA at least for now.

Thanks for the suggestions!

@jerrm is correct. ZHA share no code what so ever with Zigbee2MQTT, and vice versa. ZHA is based on zigpy libraries while Zigbee2MQTT is based on zigbee-herdsman libraries, (and other independent projects are also using those libraries).

Sometime there is however some high-level colaboration between developers and users all those projects, like when it for example comes to narrowing down and finding unusul device firmware bugs that are causing issues which can be seen in all projects regardless on what libraries that they are based on.