Haaska account linking unsuccessful

I have been using the older haaska skill for ages and decided that it was time to upgrade to the new version so that I could get the SmartHome v3 capabilities. I wiped my previous install and followed the guide here. After completing the instructions, I created a test and it passes when executed with a 200 return.

When I attempt to link the skill, I get a “linking unsuccessful” message returned, with suggestions to look at the RFC for OAuth.

More details:

I don’t know if this is pertinent, but I’m reverse-proxying 443 to hass on 8123 at my border and adding LE certs there. So, one difference in my setup vs. the guide is that 443 is open but 8123 isn’t. Opening 8123 to hass doesn’t seem to make any change, and the router config worked with the previous haaska deployment without problems.

Hi @luma - this is an error in the “Login with Amazon” / Security Profile section. Let me get my notes…

@luma In the General tab of your Haaska Security profile, did you put a “Consent Privacy Notice URL”?

It can be anything, even http://www.example.com, but it has to be filled in or else your Auth won’t work.

In the General tab of the Haaska Security Profile I don’t find any field matching that description. In the Alexa Developer Console under Distribution I find a Privacy Policy URL which I have filled out. I suspect I’m probably looking in the wrong spot…


1 Like

What did you end up changing? I’m having the same issue, and I can’t find the "Consent Privacy Notice URL”?

  1. AWS Console
  2. Settings
  3. Security Profiles
  4. Select your Haaska Security Profile
  5. Click edit
  6. Enter a valid URL for the Consent Privacy Notice URL field

Thanks! It turns out that my problem was creating the wrong kind of security profile. From a comment on this post http://collingwood.me.uk/blog/index.php/hass-io-and-alexa/

I figured out my issue… I had created the Security Profile via “Apps & Services” rather than with the “Login with Amazon”… After I when to “Login with Amazon” and used my existing created profile, added a privacy policy URL and icon, and restarted my Alexa App on my phone, I was able to link the account finally. Cheers, -G

1 Like

I have done everything right. tested and get successful in lambda but when I link I get this.

We’re sorry!

An error occurred when we tried to process your request. Rest assured, we’re already working on the problem and expect to resolve it shortly.