[HACK] Runnig Home Assistant OS from a non VM supporting Synology NAS

Yes, this is a hack and proof of concept.

Perhaps we can build the required modules (drivers) for the DSM 7 kernel too. But this is just to show that there exists options.

I might save up to a model that supports VM natively myself (the DS220+ looks promising, and is not super expensive compared to).

1 Like

I will try to update synoKVM package tomorrow. I’ve got DS216+ with RAM upgraded to 8GB and it is definitely capable to virtualize stuff. No idea why Synology decided that it is not.

BTW what’s the kernel on DSM 6.x?
This from DSM 7 doesn’t really look like something recent :slight_smile:

[email protected]:~$ uname -a
Linux backup 3.10.108 #41222 SMP Fri Dec 4 18:58:40 CST 2020 x86_64 GNU/Linux synology_braswell_216+
uname -a                                                            
Linux SynHome 3.10.105 #25426 SMP Tue May 12 04:44:40 CST 2020 x86_64 GNU/Linux synology_braswell_716+II

It looks like you didn’t manage to load the module provided un synoKVM.

synoKVM doesn’t provide module. It’s available in regular Synology kernel.

sorry for my weak testing, but the problem may be that I have a DS220 +
by the way, what would the procedure look like if for DS220 + ?

No problem., I needed to write down what we found…

If you have a ds220+ you shouldbe able to run https://www.synology.com/en-global/dsm/packages/Virtualization and just add the image from there.

I found for the first error (I think) : it’s because my bond network.
But for the second, I don’t why

For information, I run Xpenology on a HP n54L.

 uname -a
Linux mon-serveur 3.10.105 #25426 SMP Mon Dec 14 18:46:52 CST 2020 x86_64 GNU/Linux synology_bromolow_3615xs

What I have to do?

Well, if you are running a virtual machine it should be easy…

Just start another vm with hass-os.

This is not a VM.

Why do you think I run a VM?

So this works?

sudo /sbin/insmod /lib/modules/kvm-intel.ko nested=1 enable_apicv=0

Because of this https://www.wundertech.net/how-to-install-xpenology-on-a-linux-kvm-qemu-virtual-machine/

But it seems like virtual machine manager might work for you.

Xpenology isn’t installed on a VM but directly on my HP N54L.

(For the moment, I can’t access anymore to my NAS : it says there is no more place on my disk. Impossible to access to it by ssh…But it’s an other issue).

I’ll come back when it will be resolved.

Yeah modules are there. I think what synoKVM does is compiling libvirt / qemu tools to make use of these modules.

[email protected]:~$ sudo /sbin/insmod /lib/modules/kvm-intel.ko nested=1 enable_apicv=0 
Password: 
[email protected]:~$ sudo lsmod | grep kvm
kvm_intel             125880  0 
kvm                   348611  1 kvm_intel

Ok, so there are some confusion even here. This hack was kind of a workaround for models that don’t have VMM available.

Here is a guide to the VMM version: Installation on Synology Virtual Machine Managager

@BeardedConti Perhaps you can help me with a better guide…

1 Like

:smiley: You are so fast, I can’t follow you :smiley:
Currently testing on my recording (Xpenology) setup - need also to try it on non-VM 415+.

1 Like

I’m curious, do not all Synology NAS’s support Docker? Mine has a package to install Docker on it and then you can just add HA to Docker… Am I missing something?

You will miss all the nice addons…

Oooh, ok, I knew I was missing something.

I tried a VM but decided I did not like it being dependent on the Host for it to stay running so I just spent the $85 for the Raspberry Pi with a POE card so that there were less cogs in the system since it runs my lights.

@fredrike, I found what happened : “hassos_ova…” and OVMF.fd" files was been downloaded on my system partition (/dev/md0) that explains why my Xpenology said that my disk was full).

So, where i have to downloaded this files ? in tmp?

This is the error I had :

/var/packages/synokvm/target/synokvm/bin/qemu-system-x86_64: /lib/libcrypto.so.1.0.0: no version information available (required by /usr/local/synokvm/lib/libspice-server.so.1)
/var/packages/synokvm/target/synokvm/bin/qemu-system-x86_64: /lib/libssl.so.1.0.0: no version information available (required by /usr/local/synokvm/lib/libspice-server.so.1)
Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory

I specify that VMM doesn’t work on my N54L that why I’d like to use this solution.

Edit :
Question : Is this reserved to intel proc? Mine is an AMD (Turion)

1 Like